Content Collaboration - can't comment, but no errors in console

Member since: 2010

Hi, I have installed content collaboration in an Intranet project using Owin. 

That means I already have a startup class, so I included to it this part:

            var configuration = new HubConfiguration
            {
                EnableJSONP = true,
                EnableDetailedErrors = true
            };
            app.MapSignalR(configuration);

(copied from disassembled ContentCollaborationOWINStartup). (I have also tried not to do that, but to switch the startup class in web.config, then to switch back to mine)

My site is hosted on Azure, so I can't clear temporary files, but I've deployed directly from VS using "Remove additional files at destination" (which should be clearing temp files).

This is how my console looks like when I refresh the edit mode:

http://prntscr.com/ap7biw

And this is the additional console logging when I try to post a comment:

http://prntscr.com/ap7bsr

No errors in the log file when trying to post the comment.

Any ideas what else I can do to figure out what's wrong?

#147195 Apr 07, 2016 11:58
  • Hi Marija

    Did you resolve your issue? I'm trying to achieve the same thing - I tried this:

    new EPiServer.ContentCollaboration.SignalR.ContentCollaborationOWINStartup().Configuration(app);

    But I have the same issue as you.

    Thanks

    Tim

    #151381 Jul 19, 2016 11:21
  • Member since: 2010

    Hi, Tim,

    It seems that the order of registration fixed the particular issue with commenting for me - I got the fix from Epi support, they advised me to move the mapping of signalr after setting up Owin authentication.

    That all seems to work fine, however, I could still stumble upon issues with notifications and I had to rewrite Owin membership/role provider not to use HTTP context, since CC calls GetAllUsers.

    Even then, I got a new issue which occurred sometimes (doh) on any of the environments, I couldn't spot the pattern. http://world.episerver.com/forum/developer-forum/-Episerver-75-CMS/Thread-Container/2016/6/notification-settings-for-content-collaboration-don39t-work/ 

    Eventually, the client agreed that we shouldn't put more time to it and that we should switch to Projects. 

    BR,
    Marija

    #151452 Jul 22, 2016 9:23
  • Hi Marija

    Thanks for your response it was very helpful and helped identify my issue. It was in fact the following line:

    new EPiServer.ServiceApi.Startup().Configuration(app);

    For some reason this breaks content collaboration commenting functionality. I don't think I'm using the service API so have just commented it out.

    Thanks

    Tim

    #151453 Jul 22, 2016 9:55