Problem with edit-mode when upgrading 7.5 -> 9.7.2


Tried updating a site from 7.5 -> 9.7.2 by just updating the nuget packages. Worked pretty well except the edit-mode broke in stage and produktion. Id don't get errors in dev-console or 404 when loading resources.

This is what i get in edit mode:

If i try to add a gadget in the edit-tree panel i get a js-error i dev-console saying: widgets.js:2 Uncaught TypeError: Cannot read property 'id' of undefined

I had a problem adding gadgets to the dashboard as well, i got an error there about remapping EPiServer.Shell.Storage.ComponentData in the bigtable which I did and that helped that problem. That lead me to check the bigtable and compare local to stage/prod and it seems gadgets are just not added in stage/prod. I can't see all the components there as they are visible in dev. This might be why I don't get any errors? Perhaps the upgrade somehow when slightly wrong and couldn't add the right gadgets?

Has anyone had this problem? Or know if it is possible to "reset" the edit mode to ensure that mandatory gadgets are added as they should be?

Mar 18, 2016 9:09

You can reset your personalized view settings by clicking on your login up to the right in edit mode. Then My Settings -> Display options -> reset views.

I've had this problem in serveral upgrades and this have solved the issue every time

Edited, Mar 18, 2016 12:00
<p>Awsome Jonathan! Did the trick! Very appriciated!</p>
Mar 18, 2016 12:11
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.