Why does aspnet_Profile_GetProperties get called on every request in edit mode

Member since: 2010

Hi, 

We've had performance issues that I've posted here: http://world.episerver.com/Modules/Forum/Pages/Thread.aspx?id=171208 

Now, I managed to get further ahead with profiling and I've noticed that on every request in edit mode (ex.  /xx/cms/Stores/contentstructure, /xx/cms/Stores/sitestructure/..), database gets hit calling aspnet_Profile_GetProperties. Is there something I can do about this? This is just a part of requests, but you can see a database icon on the right: http://prntscr.com/db9nct

I'll also get the info to support, but if anyone has an idea, let me know.

Thx,

Marija

#172159 Edited, Nov 24, 2016 16:21
  • Member since: 2010

    I should also mention that the query that is caught by the profiler has the date format that is not recognized when I try to execute it directly in SQL manager studio, but the profiler doesn't mark this as erronious and might be that it just presents the date wrong.

    This is the query for the sake of completeness:

    EXEC dbo.Aspnet_profile_getproperties
    @ApplicationName = 'EPiServerSample', @UserName = 'username', @CurrentTimeUtc = '2016-11-24T15:14:26.3079162Z'

    BR,

    Marija

    #172160 Nov 24, 2016 16:24
  • Member since: 2010

    Hi,

    I just got a notification that the fix for this will be released with version 10.6.0 if anyone is wondering.

    #174996 Feb 09, 2017 11:12
  • Member since: 2011

    Hi Marija,

    Thank you for all your information on this problem.

    We have had the same issues, that were indeed increased by Projects as you said in http://world.episerver.com/Modules/Forum/Pages/Thread.aspx?id=171208 and your posts have been most helpful.

    Are you working around it in some way atm, and did you get any hints on when 10.6.0 could be released with this much needed fix?

    #175376 Feb 17, 2017 12:27
  • Member since: 2010

    Hi, Marie,

    I've only improved overall performances of the app, I didn't build a workaround. I tried to turn off the sqlprofile in web.config, but it is required (I do not remember what for, but I am pretty sure I couldn't live without it). I had an idea of rewriting this to my own implementation, but didn't have time to do so. I believe that it's the best to wait for the fix and I doubt we can get a definitive answer on the release date, but I guess it will be there pretty soon. Perhaps a bit delayed due to Ascend Vegas.

    Not a fix from me, but hope this helps as well :)

    #175388 Feb 17, 2017 18:33
  • Member since: 2011

    Ok, thank you. :)

    #175433 Feb 20, 2017 10:59
  • Member since: 2014

    CMS UI 10.6.0 is now available.

    #175484 Feb 21, 2017 20:06