HTTP 404: The resource cannot be found.

Vote:
 

Hi, 

I am stuck in very annoying sitatuation. I created new empty Episerver 8 Website project in my solution from Visual Studio. I set up everything (as far as i know. In IIS and everywhere in project). I can access Episerver Edit mode can create pages & set StartPage in Episerver but when i try to access website though I end up in following error

Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.81.0

_______________________________________________________________________

I am already running another instance of Episerver 7.1 on same computer & IIS. I am scratching my head here dont know what to do.

#133056
Aug 25, 2015 17:39
Vote:
 

Have you created at least one page and then configured a startpage in admin for the host you're trying to access?

#133100
Aug 25, 2015 19:58
Vote:
 

Hi Johan,

Yes i did I created a startpage and went to Adim=>Config=>Manage Websites and set the Start page there. Still eneded up with the same error as mentioned above.

#133124
Aug 26, 2015 10:13
Vote:
 

We are having the same problem. The start page is available and configured and visible in EpiServer CMS but not available once you try to view it via a browser. We have two other sites that work fine and this site was working up until two days. The other thing that is curious is that when you place the visual studio project in debug mode while the site is invoked in CMS the start page is not available in the usual place as with other sites. For example:

var pageRouteHelper = ServiceLocator.Current.GetInstance<IPageRouteHelper>();
var page = pageRouteHelper.Page as MultisiteStartPage;

For the sites that are rendering fine via a browser the page variable has a value while for the site where "the resource can not be found" the page is null and we have to retrieve it as a child from the first ancestor in the tree.

#184424
Oct 26, 2017 14:22
Vote:
 

Re-install Episerver via Nuget

#189827
Mar 26, 2018 4:19