Nuget Error Adding EPiServer.ServiceApi

Vote:
 

I am trying to add EPiServer.ServiceApi to the Quicksilver commerece site (https://github.com/episerver/quicksilver) and also to a commerce solution I am working on.

I am currently getting this error:

Attempting to resolve dependency 'EPiServer.Cms.Core (≥ 8.1.0 && < 9.0)'.

Attempting to resolve dependency 'EPiServer.Framework (= 8.9.0)'.

Attempting to resolve dependency 'Newtonsoft.Json (≥ 5.0.8 && < 7.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.Mvc (≥ 4.0.20710.0 && < 6.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.WebPages (≥ 3.2.3 && < 3.3.0)'.

Attempting to resolve dependency 'Microsoft.Web.Infrastructure (≥ 1.0.0.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.Razor (≥ 3.2.3 && < 3.3.0)'.

Attempting to resolve dependency 'structuremap (≥ 2.6.4.1 && < 3.0)'.

Attempting to resolve dependency 'EPiServer.Logging.Log4Net (≥ 1.0 && < 2.0)'.

Attempting to resolve dependency 'log4net (= 1.2.10)'.

Attempting to resolve dependency 'Castle.Windsor (≥ 3.2 && < 4.0)'.

Attempting to resolve dependency 'Castle.Core (≥ 3.3.0)'.

Attempting to resolve dependency 'Owin (≥ 1.0 && < 2.0)'.

Attempting to resolve dependency 'System.IdentityModel.Tokens.Jwt (≥ 3.0 && < 5.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.WebApi (≥ 5.1.2 && < 6.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.WebApi.WebHost (≥ 5.2.3 && < 5.3.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Core (≥ 5.2.3 && < 5.3.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Client (≥ 5.2.3)'.

Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Owin (≥ 5.1.2 && < 6.0)'.

Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Core (≥ 5.1.2 && < 5.2.0)'.

Updating 'Microsoft.AspNet.WebApi.Core 5.2.3' to 'Microsoft.AspNet.WebApi.Core 5.1.2' failed. Unable to find a version of 'Microsoft.AspNet.WebApi.WebHost' that is compatible with 'Microsoft.AspNet.WebApi.Core 5.1.2'.

#123567
Jul 08, 2015 15:08
Vote:
 

Did anyone ever find a resolution on this? I am also getting this error. I'm on Episerver 8, with MVC and using Visual Studio 2013.

-Paul

#142665
Dec 17, 2015 22:55
Vote:
 

It could be another case of NuGet 2.x dependency resolution issues. We have collected some troubleshooting in this article. Basically the first thing to try if possible is to use VS 2015 since Nuget 3.x where the issues are fixed are not available for VS2013.

#142696
Dec 18, 2015 13:48