Disable loginprompt

Member since: 2007

Hi all

upgrade from 6r2 to CMS version 7.19.2

How do i disable the default login prompt from episerver?

I have several login pages for different extranets, ive made a handler to redirect to the right loginpage. but the default episerver comes in before my handler is executed.

Any idea?

Regards

#120059 Apr 09, 2015 12:26
  • Member since: 2011

    What you have in <authentication /> element in web.config?

    #120061 Apr 09, 2015 13:42
  • Member since: 2007
      <authentication mode="Forms">
          <forms name=".EPiServerLogin" loginUrl="templates/public/pages/common/login.ashx" timeout="1440" />
        </authentication>

    #120062 Apr 09, 2015 13:45
  • Member since: 2011

    And the .ashx guy does redirect to correct login page based on extranet?

    #120063 Apr 09, 2015 13:59
  • Member since: 2007

    yes, depanding on return-url it redirects to the right extranet. But the episerver default prompt is poping up before my ashx. isnt it any classic mode? with a loginpage?

    #120064 Apr 09, 2015 14:05
  • Member since: 2005

    By episerver default prompt, do you mean the one at /util/login.aspx?

    #120140 Apr 10, 2015 15:49
  • Member since: 2007

    Nope, it is a popup login prompt, like the one on windows login in web browsers, but in all browsers. is it just me? i thought that was the default prompt... is it an IIS thing?

    #120141 Apr 10, 2015 15:53
  • Member since: 2005

    Yes, Windows Login prompt suggests you need to look at your IIS settings. You should have it set for Anonymous access.

    It could also, depending on your other config, have something to with Permissions on disk.

    If you run integrated mode you can't combine a HTTP Authentication login prompt with Forms Authentication. This worked on IIS6.

    #120146 Apr 10, 2015 16:19
  • Member since: 2007

    It is really strange, i ve been looking all over my windows server 2012 configurations, i do have Forms authentication activated, and i do login in with the episerver membership credentials, and not any windows account. I do run the IIS AppPool as NetworkServices. Permissions on disk is set. I have this on dev, test and prod server. Im confused ...

    #120228 Apr 13, 2015 21:59
  • Member since: 2011

    Maybe some other settings in web.config is causing popup window to show up. For instance <location> element defined for "templates" folder?

    #120229 Apr 13, 2015 22:17
  • Member since: 2007

    by removing

    <add name="BasicAuthentication" type="EPiServer.Security.BasicAuthentication, EPiServer" />

    from web.config  <modules runAllManagedModulesForAllRequests="true">

    Its working without prompt. what is EPiServer.Security.BasicAuthentication? legacy?

    It seems that EPiServer.Security.BasicAuthentication is like two-level authentication using Forms Authentication and Windows Authentication.

    #120294 Apr 14, 2015 18:00
First   1 2   Last 
This topic is locked because the last reply was posted more than 6 months ago. Please contact epw@episerver.com to unlock it.