[Bug?] Not able to get RenderSettings from ContentControlBase

Member since: 2007

Hi,

I have a simple local block with address data. I'm rendering the block with the property control:

<EPiServer:Property runat="server" PropertyName="VisitingAddress">
    <RenderSettings Heading="Visiting Adress" />
</EPiServer:Property>

My renderer inherits from ContentControlBase, which in turn inherits from UserControlBase which implements IRenderSettings. But the RenderSettings property is always empty! Even if I add one of the typed settings like Tag, it's still empty.

However, if I traverse the control tree up to the PropertyDataControl, I can find all the settings.

Is this is a bug? Shouldn't the renderering settings be set in ContentControlBase?

I blogged about this a while back before I knew about IRenderSettings, http://dodavinkeln.se/post/custom-rendering-settings. Then I tried to access RenderSettings in a shared block, and that worked! But it seems like it doesn't work with local blocks.

#87735 Jun 21, 2014 0:02