MVC 5.0

Vote:
 

Hello,

Does anyone know if CMS and Relate 7.5 will work with MVC 5.0? Has anyone used MVC 5.0 with EPiServer yet?

Mark

#85358
Apr 23, 2014 16:48
Vote:
 

I'm assuming it would, just wanted to double check...

#85359
Apr 23, 2014 16:49
Vote:
 

I don't use relate yet but I will be using MVC 5.0 in my blogserie "The ultimate EPiServer Windows Azure Website" (http://world.episerver.com/Blogs/Henrik-Fransas/Dates/2014/4/The-ultimate-EPiServer-Windows-Azure-website-part-1/) and the hardest part for me has been to migrate it up to Framework 4.5

But to your question, yes is should work

#85360
Apr 23, 2014 16:57
Vote:
 

Hi Henrik!

What's the issues you have been having getting it up on 4.5? I've upgraded several Alloy sites without any issues but I'm interested if there are more issues in real live sites. The only issue I know of is that you need to install an VS upgrade to be able to target .NET 4.5 or 4.5.1 if you are still on VS 2012. With VS 2013, this seems to work automatically.

#85409
Apr 24, 2014 14:06
Vote:
 

Linus, the issue I had was that the visual studio extension created a project with framwork 4.0 even that I had choosed framework 4.5 when I press create project. Because of that, I had to do some manual work to change the target framework to 4.5, like reinstall all the nuget package. If you read http://world.episerver.com/Blogs/Henrik-Fransas/Dates/2014/4/The-ultimate-EPiServer-Windows-Azure-website-part-1/ you can see more in detail.
After doing that it all work

#85411
Apr 24, 2014 14:14
Vote:
 

Ok, thanks for the feedback. I have been trying to push an upgrade to .NET 4.5.1 for quite a while and we are actually coming our with a few add-ons in the near future that requires this to be installed. I hope we can upgrade pretty soon as I've also noticed that it's quite disturbing when you need to upgrade zillions of NUGET dependencies to get up to the latest and greatest.

#85412
Apr 24, 2014 14:19
Vote:
 

Linus
I totaly agree. A little tip (sorry Mark for hijacking this thread) is that the extension didn't see that there were a upgrade last time, I had to do a manual uninstall / install to get the latest version.

#85413
Apr 24, 2014 14:24