GA Add-on installation for EPiServer 7.19.1

Member since: 2010

Hi, guys,

Has anyone tried to install GA add-on on newer sites?

I've seen this blogpost:

http://world.episerver.com/blogs/Steve-Celius/Dates/2014/12/google-analytics-tracking-and-customization/, but as explained in the last comment, it seems to require the older version of EPi. I guess I should contact the support after the holidays, but if anyone sees this in the meantime and has a workaround, pls let me know.

Thx and happy holidays!!

#114911 Dec 31, 2014 13:34
  • Member since: 2010

    Now I have it as a normal EPiServer Add-on, last time I tried, it wasn't there. I haven't now tried to install it from package management console, so might be that this is what is not working.

    #114914 Dec 31, 2014 14:25
  • Member since: 2012

    Installing GA add-on from Addon Store works for you as opposed to pulling directly from NuGet?

    #114918 Dec 31, 2014 20:10
  • Hello,

    I tried to reproduce the issue and met the same problem when the EPiServer.CMS.UI version 7.18.1 is not installed. (Only upgrade the EPiServer.CMS.Core, EPiServer.Framework, EPiServer.CMS.UI.Core). The error details is:

    Updating 'EPiServer.Framework 7.18.0' to 'EPiServer.Framework 7.5.394.2' failed. Unable to find a version of
    'EPiServer.Packaging' that is compatible with 'EPiServer.Framework 7.5.394.2'.

    When I install the latest version for EPiServer.CMS.UI, GA can be installed properly without any error. Is it your issue?

    #114958 Jan 06, 2015 9:48
  • Member since: 2010

    Hi, guys,

    Thx for your responses. I do get the error when I try installing from the console. The error is almost the same as yours, Duc:

    install-package : Updating 'EPiServer.Framework 7.15.0' to 'EPiServer.Framework 7.13.2' failed. Unable to find a version of 'EPiServer.Packaging' that is
    compatible with 'EPiServer.Framework 7.13.2'.
    At line:1 char:1
    + install-package EPiServer.GoogleAnalytics
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

    However, all my nuget packages are up-to-date:

    <package id="EPiServer.CMS.Core" version="7.19.1" targetFramework="net45" />
    <package id="EPiServer.CMS.UI" version="7.18.1" targetFramework="net45" />
    <package id="EPiServer.CMS.UI.Core" version="7.18.1" targetFramework="net45" />
    <package id="EPiServer.Framework" version="7.19.1" targetFramework="net45" />
    <package id="EPiServer.Logging.Log4Net" version="0.1.0" targetFramework="net45" />
    <package id="EPiServer.Packaging" version="3.2.0" targetFramework="net45" />
    <package id="EPiServer.Packaging.UI" version="3.2.0" targetFramework="net45" />
    <package id="EPiServer.Search" version="7.7.0" targetFramework="net45" />

    When I tried to uninstall packaging packages (since this is what the error suggests -> "Unable to find a version of 'EPiServer.Packaging' that is 
    compatible with 'EPiServer.Framework 7.13.2'.", the same error occurs.

    Any ideas?

    #115036 Jan 08, 2015 11:59
  • Member since: 2012

    I attempted to reproduce this issue by installing GA via NuGet on a Commerce 8.6 site. I couldn't get the same error. 

    Not sure if you've seen this guide, but please review it in case something is missing in your VS setup - http://world.episerver.com/documentation/Items/Developers-Guide/EPiServer-CMS/75/Modules/Installing-add-ons/

    #115073 Jan 09, 2015 0:37
  • Member since: 2009

    Hi,

    I try to reproduce the issue several times but not success. It's quite hard to address your issue without touching your environment. If you're trying to install GA (via nuget) to an existing site. Please open a support case so our Supporter can debug it properly.

    In case you want to install GA (via Nuget) to a new site, and to avoid any mis-step, please strictly follow these simple steps:

    • Install a new Alloy or AlloyMVC site with DeploymentCenter, this will be CMS 7.5
    • Upgrade the site to latest (7.19) by
      • Open the site project by Visual Studio , save Solution File, Update project to use .NET 4.5.2
      • Add a Nuget feed (name it as "EPiServer Public Nuget Feed") with URL:  http://nuget.episerver.com/feed/packages.svc/
      • Select "EPiServer Public Nuget Feed" in the combobox. Upgrade site by installing the CMS nudgets (they are in order)
        • install-package EPiServer.CMS.Core
        • install-package EPiServer.CMS.UI
        • install-package EPiServer.Packaging.UI
      • Run cmdlet update-epidatabase 
      • Run cmdlet Move-EPiServerProtectedModules
      • Rebuild solution

    Then install-package EPiServer.GoogleAnalytics

    #115081 Edited, Jan 09, 2015 5:17
  • Member since: 2010

    Hi, guys,

    Thx for all of your ideas. I have had the latest versions of all EPiServer packages and protected modules were in the right place ofc.

    However, it seems that this error occurs when other packages have some sort of conflict.

    There was an issue with two versions of Newtonsoft.Json in the packages folder that were probably troublemakers. Now that I have only one, packages are working correctly.

    #115381 Jan 14, 2015 11:17
  • Member since: 2009

    Hi,

    In the latest release of GA, we specified:

    --- Separate EPiServer Commerce Support from Google Analytics core package. Merge Configuration DLL into the main DLL.
    --- Breaking changes: Using REST. Remove external dependencies (json.NET, Google APIs, Google Analytics APIs, DotNetOpenAuth).

    There is no direct dependency to Newtonsoft.Json from GA. So I can assure that if your site is clean, GA runs.

    I agree with you that conflicting of two version of Newtonsoft.Json is the root problem.

    We're happy that you are enjoying GA right now.

    T.

    #115382 Jan 14, 2015 11:22