Bug in 7.5?

Vote:
 

Hi All,

We have required fields set on images for "alt text", if you upload a new image, it will be added to the library, but remain as "Yet to be published" because the alt text is missing. *great*

*but* :( ......  Editors can still insert the image into a page and publish the page. The page is then publshed and live with an image that is not published.

So effectively, you can publish unpublished content.

I can't find the bug tracker to see if this has been fixed or where I can add this, do Episerver monitor this forum? Anyone know how to get to the bug tracker for episerver?

Thanks,
Paul

#113058
Nov 12, 2014 5:24
Vote:
 

Hi!

Public bugs can be found here: http://world.episerver.com/Support/Bug-list-beta/

Regarding this specific issue, I would not consider it a bug. Content that have not been published yet can be used by other content, for instance creating a link to a yet unpublished page from another page or inserting a yet to be unpublished block on a page.

I do understand your concern however, and will mention how I think that this is best addressed. There is a pretty new feature (still in beta) that is called projects (http://world.episerver.com/Blogs/Magnus-Stalberg/Dates/2014/8/Projects-Beta/). This makes it possible to work with more than one item at the same time and also publish all items with one action. However, you still have to manually add items to the project. It's my strong belief that having a "project mode" where all actions you do would get into the project. This would mean that both the uploaded files as well as your changed/new blocks/pages would be added to the current project and when your are done you would just publish the items in the project. I know that this has been discussed in the development department but it's currently not part of the near future. I still hope that we can add this since I think it's a key feature for the editor workflow.

#113059
Nov 12, 2014 7:20