Automatic workflows don't get triggered

Member since: 2010

Hey, I'm trying to make workflows work (I've set up parallel workflow as in documentation, scheduler is set to active in episerver.config) and clicked ready to publish. I don't get any errors, but the email is not sent and I can't see the any active workflows in admin mode.

Since I don't get any errors, I've set up the diagnostics as per Mark's post: http://www.markeverard.com/2010/06/01/debugging-workflows-and-httpcontext/

I get this in the Visual Studio Output window:System.Workflow.Runtime.Hosting Information: 0 : SqlWorkflowPersistenceService OpenConnection start: 11/28/2014 09:03:56

System.Workflow.Runtime.Hosting Information: 0 : SqlWorkflowPersistenceService OpenConnection start: 11/28/2014 09:03:56
System.Workflow.Runtime.Hosting Information: 0 : SqlWorkflowPersistenceService. OpenConnection end: 11/28/2014 09:03:56
System.Workflow.Runtime.Hosting Information: 0 : SqlWorkflowPersistenceService.RetrieveExpiredTimerIds ExecuteReader start: 11/28/2014 09:03:56
System.Workflow.Runtime.Hosting Information: 0 : SqlWorkflowPersistenceService.RetrieveExpiredTimerIds ExecuteReader end: 11/28/2014 09:03:56

The time seems off for 1h. 

I am on IIS express.

Is there anything I am doing wrong? How do I get a more informative status?

#113801 Nov 28, 2014 10:05
  • Member since: 2010

    The automatic workflow functionality doesn't work on test either.

    #113802 Nov 28, 2014 10:07
  • Member since: 2004

    Try to turn on log4net logging in namespace "EPiServer.WorkflowFoundation"

    #113853 Nov 28, 2014 13:12
  • Hi Marlja,

    Make sure you have a valid smtp server configured in your config file, it will try to send an email.

    I usually set up a dummy local domain and use smtp4Dev http://smtp4dev.codeplex.com/ it is a great tool.

    Cheers,

    Paul

    #113880 Dec 01, 2014 5:35
  • Member since: 2010

    Bad luck for me while setting this up, I thought it was sth wrong with my setup of workflows. Instead, SMTP server was under maintainance. Thx a lot for your help!

    #113883 Edited, Dec 01, 2014 9:19