Officetillägg i CMS

Vote:
 

Jag har precis börjat kika på versionshantering i CMS. Har provat att publicera dokument från Word rakt in i EPiServer och det har funkat fint. Om man däremot går tillbaka till arbetet med versionshantering genom Officeprogrammet av en fil som finns i filhanteraren så har jag stött på ett problem som är lite knepigt.

Det är så att när jag högerklickar på en fil som jag vill redigera i Office (Word) väljer jag checka ut. Det funkar bra. Sedan högerklickar jag igen och väljer jag Redigera i Office. Där kommer problemet. Då får jag nämligen upp en dialogruta  som säger följande: Denna webbplats är inte aktiver i Officetillägget.

Jag blir en smula konfunderad över detta. Och förstår inte hur jag ska göra för att få webbplatsen att stöda officetillägget. Någon som varit ute för detta och vet om man ska gå in i adminläget i EPi och göra någon ändring eller är det något annat man ska ändra på?
Ralf Sundhäll
Marks kommun

#31485
Aug 03, 2009 10:30
Vote:
 

För att man ska kunna publicera från MS Office till EPiServer CMS, behövs förutom rättigheter, ett par saker till:

  1. En komponent som gör att man får upp en EPiServer-knapp i respektive Office-applikation (Word, Excel, PowerPoint).
  2. Varje webbplats som man vill publicera till måste dessutom aktiveras innifrån EPiServer CMS.

Du hittar både installationen av komponenten och aktiveringen av webbplatsen i EPiServer CMS, i redigeraläget i sidträdet, om du markerar rotkatalogen högst upp. Där finns en flik som heter Microsoft Office-tillägg. Därifrån kan du både installera Office-tillägget och aktivera webbplatsen.

Det verkar som det sistnämnda inte är gjort för den aktuella webbplatsen.

 

#31576
Aug 03, 2009 15:27
Vote:
 
Ok. Jag förstår. Tror jag :) Knappen eller snarare  ien menyflik som heter Tillägg där under finner man Publicera till EPiServer CMS i de olika Officeapplikationer som jag behöver det i. Det funkar bra.

Däremot så går det inte lika bra när jag försöker aktivera MIcrosoft Office-tillägget i EPiServer. Har gått in under rotkatalogen och sedan fliken Microsoft Office-tillägg. Där har jag sedan klickat på Installera. Får då svaret att jag använder verion 2.2 av Microsoft Office-tilägg. Ok. Försöker då att klicka på Aktivera. Då händer ingenting. Förutom att det står att "Denna webbplats är inte aktiverad för publicering från din dator" Vilket är precis vad jag vill göra. Får en känsla av att jag har missat något. Eller har du någon aning om vad jag gör för fel?
#31593
Aug 04, 2009 10:13
Vote:
 
#31594
Aug 04, 2009 10:16
Vote:
 

Ok. Jag förstår. Tror jag :) Knappen eller snarare  ien menyflik som heter Tillägg där under finner man Publicera till EPiServer CMS i de olika Officeapplikationer som jag behöver det i. Det funkar bra.

Däremot så går det inte lika bra när jag försöker aktivera MIcrosoft Office-tillägget i EPiServer. Har gått in under rotkatalogen och sedan fliken Microsoft Office-tillägg. Där har jag sedan klickat på Installera. Får då svaret att jag använder verion 2.2 av Microsoft Office-tilägg. Ok. Försöker då att klicka på Aktivera. Då händer ingenting. Förutom att det står att "Denna webbplats är inte aktiverad för publicering från din dator" Vilket är precis vad jag vill göra. Får en känsla av att jag har missat något. Eller har du någon aning om vad jag gör för fel?

#31595
Aug 04, 2009 10:17
Vote:
 

Kontrollera att rättigheterna är satta som de ska för den webbplats som du försöker publicera till. Man behöver sätta rättigheter i Admin-läget under Konfig/ Säkerhet/ Åtkomst till funktioner. Be en systemadministratör om hjälp om du inte har Admin-rättigheter.

Vilken version av EPiServer CMS använder ni? Kan vara något annat problem, kontrollera exempelvis detta: http://world.episerver.com/en/Articles/Items/EPiServer-Office-Integration-Security-Advisory/

Kanske denna Tech Note (gäller för EPiServer CMS 5 R2) kan vara till hjälp för att felsöka vidare, den beskriver hur Office-integrationen fungerar, se delen som handlar om "Security issues": http://world.episerver.com/en/Documentation/Items/Tech-Notes/EPiServer-CMS-5/EPiServer-CMS-5-R2-SP2/Microsoft-Office-Integration/

#31596
Aug 04, 2009 10:41
Vote:
 
Det var intressant detta :) Gjorde som du tipsade om och gick in i adminläge under Konfig/Säkerhet till funktioner. Där finns ju "Visa och publicera sidor från Microsoft Office-tillägg" De grupper som har möjlighet att göra och som finns där under finns jag med i. Konstigt. Vad tror du man kan göra nu?

Vi har EPiServer version CMS 5.2
#31597
Aug 04, 2009 10:53
Vote:
 

Har kollat runt lite - säkerhetsinställningarna i Vista (UAC) kan orsaka problem vid aktiveringen av webbplatsen. prova att lägga till siten i Trusted Sites, om du kör Vista. Som sagt - det finns en säkerhetsfix för ATL, se länken jag refererade till i föregående inlägg.

Vi arbetar just nu med en säkerhetsuppdatering av komponenterna, håll utkik efter mer info på EPiServer World.

#31611
Aug 04, 2009 11:44
Vote:
 
Vi kör tyvärr inte Vista. Utan Office 2007. Kollade dock i tillförlitliga webbplats och där fanns mark.se med.

Däremot har det hänt saker nu utan att jag förstår varför. Det var nämligen så att jag provade att gå in under Officcetillägg en gång till och köra samma procedur igen.

Sedan laddade jag upp ett nytt dokumnet i filhanteraren. Provade att checka ut det och valde sedan alternativet redigera i Office. Då öppnads sig doktumentet i word. Kanon! Gjorde några ändringar. Checkade in dokumentet. Därefter skrev jag in en kort mening i versionsrutan Sedan blev det dock problem.När jag klickade ok i versionrutan fick jag upp ett felmeddelande som sade följande: Destinationskatlog saknas.

Kanske inte så lätt att svara på men har du någon aning om varför detta problem uppstår? Jag förstår inte för om jag har en mapp i filhanteraren och checkar ut ett dokumnet därifrån så bode väl det funka som destinationskatalog.
#31615
Aug 04, 2009 13:51
Vote:
 
Möjligen hänger det ihop med föregående - dvs att det är något med säkerhetsinställningarna i Office-integrationen.
#31645
Aug 05, 2009 9:57
Vote:
 
Nu har jag forskat liet mer i detta problem och med hjälp av en It-tekniker här vi lyckat lösa så att nu är webbplatsen aktiverad för oFficetillägg. Dock kvarstår ännu problemet med att jag får upp en ett felmeddelande som säger följande: Destinationskatlog saknas när jag försökre checka in ett ett dokumnet i Office efter att gjort en ändring i det.

Jag förstår inte riktigt vad som menas med destinationskatalog i detta fall. Har man laddat upp dokumentet i Filhanteraren i ett album som man sedan checkar ut det från så borde väl det albument räknas som destinationskatalog? Konstiga problem jag råkar ut för :)  
#31746
Aug 11, 2009 10:47