Last updated: Jun 13 2018

Area: Episerver Service API Applies to versions: 4 and higher
Other versions:

Upgrading to Service API 4

Service API version 4.0 contains breaking changes compared to the previous version, 3.x. These breaking changes require code changes in website implementations depending on Service API.

Breaking changes for Service API version 4.0

  • It's no longer allowed to change the content metaclass. In ServiceAPI 4.0, if you try to change the metaclass of an entry or a node, the following exception is thrown: MetaClass could not be changed.
  • _ExcludedCatalogEntryMarkets is now exposed to the MetaFields collection.

Comments