EPiServer.Commerce.Security does not work together with the latest CMS UI package

Fixed in

EPiServer.Commerce 13.30.0

Created

Feb 16, 2021

Updated

Mar 08, 2021

State

Closed, Fixed and tested


Description

The latest version of CMS UI requires at least version 4.1.1 of Microsoft.OWIN.Host.SystemWeb. However, EPiServer.Commerce.Security only supports version 3 of that dependency. So if you have Commerce installed, and try to update to the latest version of CMS you will get the following error:

 
The latest EPiServer.CMS (11.20.4) depends on Microsoft.OWIN.Host.SystemWeb >= 4.1.1; via EPiServer.CMS.UI.AspNetIdentity 11.32.1. However the latest EPiServer.Commerce.Security (13.29.0) depends on Microsoft.OWIN.Host.SystemWeb < 4.0.0
 
The suggestion is to update the dependency EPiServer.Commerce.Security's dependency to Microsoft.Owin.Host.SystemWeb to be [4,5).