EPiServer.Framework.AspNet package should have NuGet dependency on MVC 5.2.3

Found in

EPiServer.CMS.Core 11.1.0

Fixed in

EPiServer.CMS.Core 11.2.0

Created

Nov 22, 2017

Updated

Nov 27, 2017

Area

CMS Core

State

Closed, Fixed and tested


Description

New sites creating using Visual Studio integration or Quicksilver have been using MVC 5 for several years. But when upgrading from 7.5 to CMS 11, MVC 5.2.3 is not required even though it is technically required by several packages (Forms, TinyMCE, Commerce, DynamicContent etc).

EPiServer.Framework.AspNet package should have a NuGet dependency on MVC 5.2.3 to clearly indicate this.