Deprecate the old Gadget framework

Fixed in

EPiServer.CMS.UI 10.6.0

Created

Oct 07, 2016

Updated

Jul 07, 2017

Area

CMS UI

State

Closed, Fixed


Description

From CMS UI 10.6, the GadgetAttribute and all classes that use this attribute are marked as obsolete, and will be removed in an upcoming major version release. Also, all jQuery-based libraries are marked as deprecated and should not be referenced because they will be removed in the future.

For more information, see this blog post for more information: http://world.episerver.com/blogs/grzegorz-wiechec/dates/2017/1/the-old-gadget-framework-is-deprecated/