Views: 3351
Number of votes: 1
Average rating:

License error: Current version is newer than required version

In EPiServer 7.5 if you upgrade to latest update through nuget (starting from update-6) you might get a license error something like :

Current version 7.6.0.0 is newer than required version 7.5.9999

Don’t worry, you don't need to "upgrade" your license as normally is the case when upgrading from EPiServer-5 to EPiServer-6 or 6 to 7. The reason for above error is probably your license file has max version set to :

<Restrictions>
        <Restriction>
          <VersionRestriction From="7.0" To="7.5.9999" ….

EPiServer 7 license works both for 7 & 7.5 release.

Solution:

Re-generate the license file from license center (required admin access). Login to license center, go under "Licenses" tab, open the license
and click "Send license file by email". When you re-send the license file, it will automatically update the maxversion of all grouped/bundled EPiServer 7 licenses as well. So you don’t need to re-regenerate each license file separately.

If you don’t have License Admin access to license center then send a request to LicenseAdmin at episerver dot com to regenerate the license file for you.

Apr 10, 2014

Daniel Badro
( By Daniel Badro, 4/11/2014 11:07:00 AM)

Thanx for the intel, I got this error and ended upp ordering a new developer licens.
/D

Please login to comment.