Views: 3835
Number of votes: 1
Average rating:

For Those Who Had Issues Updating to Commerce 7.10

Last Friday, new updates were released for the Commerce NuGet packages. The version numbers are now 7.10.1. I am aware that many who tried to update to the older 7.10 packages were greeted with a new migration page which forced a database update. Unfortunately, it seemed that those who attempted to update to 7.10 got migration failures instead.

I am happy to note that the migration issues should be fixed in 7.10.1 and I was able to update a base Commerce 7.5 site with sample templates to 7.10.1. Via NuGet console, I installed EPiServer.Commerce and then ran “update-epidatabase” to get to the migration page on my Commerce site.

 image

Migration completed. Yay!

Clicking on “Go to start page” should direct you to your newly updated 7.10.1 site.

Information specific to what’s new in Commerce 7.10 can be hard to find, so here’s some quick links to get you in the right direction:

http://world.episerver.com/Documentation/Items/Installation-Instructions/Installing-EPiServer-updates/

[New in 7.10.0] An update may have one or more migration steps that need to be executed in order for the site to work correctly. If so, any request to the site will be redirected to a migration page. In order to access it you need to be part of the "CommerceAdmins" role. From there it is possible to run the migration steps and track the progress. Once all steps have been completed successfully the redirects will stop, and the site will be back to normal.

[New in 7.10.0] It is possible to have the migration started automatically during the sites initialization. That is done by adding an app setting called "AutoMigrateEPiServer" and setting the value to "true". However, until all steps have been completed, any requests will still be redirected to the migration page, where it is possible to track the progress.

Release Notes:

EPiServer.Commerce 7.10
EPiServer.Commerce.UI 7.10

Aug 04, 2014

Jeff Valdez
( By Jeff Valdez, 8/4/2014 7:44:46 PM)

Awesome! :)

( 8/5/2014 12:46:24 PM)

Nice!

K Khan
( By K Khan, 8/5/2014 3:10:55 PM)

Much needed

K Khan
( By K Khan, 8/5/2014 3:14:39 PM)

I was not able to login in CommerecManager after Update I created a User Group in CommerecManager 'CommerceAdmins' and added that in commerce manager. After that I was able to login on commerce manager but getting following error

http://710commercemanager.development.local/modules/Commerce/Migrate

Server Error in '/' Application.

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load type 'System.Web.Mvc.ViewPage'.

Source Error:


Line 1: <%@ page language="C#" inherits="System.Web.Mvc.ViewPage" %>
Line 2: <%@ import namespace="EPiServer.Commerce.UI.Models.Migrate" %>
Line 3: <%@ import namespace="EPiServer.Commerce.Internal.Migration" %>

Richly Chheuy
( By Richly Chheuy, 8/5/2014 5:12:06 PM)

Hi Khurram,

Thanks for raising that issue. I'll see if I can reproduce the issue. I was hoping it'd be smooth sailing after 7.10.1 :).

Richly Chheuy
( By Richly Chheuy, 8/6/2014 8:46:42 PM)

@Khurram Couldn't reproduce, we'd probably need a copy of your site and DB. Updated to 7.10.1 successfully, can login and access Commerce Manager.

Richly Chheuy
( By Richly Chheuy, 8/6/2014 8:46:44 PM)

@Khurram Couldn't reproduce, we'd probably need a copy of your site and DB. Updated to 7.10.1 successfully, can login and access Commerce Manager.

Viktor G
( By Viktor G, 9/8/2014 10:35:08 AM)

Hi,

I got the same error as Khurram after my upgrade and I think the reason was that I first visited the commerce site before I had run the migration tool on the EPiServer site. After that I was always redirected to "/modules/Commerce/Migrate" when trying to access the manager site.

/Viktor

Please login to comment.