Views: 5651
Number of votes: 0
Average rating:

Mark page as changed checked as default

If you check the EPiServer SDK they way to do it is by attaching to the EditPanel loadedpage event i Global.asax.

What if you would like to to it for different pagetypes then? It would be no big thing to add a paget ype check and maybe make it configurable through a section i web.config.

Since I don’t like neither sections in web.config or having lot’s of code in global.asax i decided to try to accomplish this with a custom property.

It turned out to be very straight forward. Just create a custom property with a control class inheriting from PropertyStringControl, and add the below code to CreateEditControls.

Just add the property to the top of the Information tab and you should be good to go.

Note: After having so colleagues trying it out it seems that neither of the two approaches work i CMS5 R2, but both do in CMS5.

   1: #region CreateEditControls
   2:     /// <summary>
   3:     /// Set "PageChangedOnPublished
   4:     /// </summary>
   5:     public override void CreateEditControls()
   6:     {
   7:         PageData pd = ((PageBase)this.Page).CurrentPage;
   8:  
   9:         if (pd.Property["PageChangedOnPublish"] != null)
  10:             pd.Property["PageChangedOnPublish"].Value = "True";
  11:  
  12:     }
  13:     #endregion

 

Global.asax code:

   1: public class Global : EPiServer.Global
   2: {
   3:     protected void Application_Start(Object sender, EventArgs e)
   4:     {
   5:         EditPanel.LoadedPage += new LoadedPageEventHandler(EditPanel_LoadedPage);
   6:     }
   7:  
   8:     protected void EditPanel_LoadedPage(EditPanel sender, LoadedPageEventArgs e)
   9:     {
  10:         e.Page.PageName += "[Test]";
  11:         e.Page["PageChangedOnPublish"] = true;
  12:     }
  13: }
Jun 16, 2010

Falted
(By Falted, 9/21/2010 12:33:24 PM)

Have you tried this approach in CMS 6?

per.nergard
(By per.nergard, 9/21/2010 12:33:24 PM)

Yes I tagged it with CMS 6 so i should have done it in cms 6.

Mpagi Kironde
(By Mpagi Kironde, 9/11/2012 7:58:10 PM)

HI Per,

I tried your solution in version 5.2.375.236, but no luck. Its driving me up the wall, Any ideas how to get it workin in 5.2

thanks

per.nergard
(By per.nergard, 4/4/2013 7:33:00 PM)

Sorry that I haven't answered. There is some problem because I don't get any mails when people comment altough I have it in the settings.

I think this is a known limitation that it doesn't work in CMS5.

Marcus Andersson
(By Marcus Andersson, 6/18/2013 1:02:18 PM)

Exactly what I was looking for!
Thanks.

Please login to comment.