Views: 10248
Number of votes: 1
Average rating:

Installing Demo Templates on CMS 5 R2 SP2 – Another Recipe

CMS R2 SP2 will be here any day now. Once you have it you will find that your favorite module does not exist in a compatible version… hmm. This is a problem we are eager to solve since it puts quite some pressure on the EPiServer organization whenever a new CMS version is released.

In the mean time, what can you do to get around this, i.e. to get a module built for an older version (R2 or R2 SP1) installed on your brand new R2 SP2 site. Well, here’s a walkthrough of how you get the Demo templates for SP1 working and the same procedure should work for most “ordinary” modules:

  1. Make sure the necessary components are installed on the machine (If you don’t have the installation bits you can download them from EPiServer World).
    1. EPiServer CMS R2 SP1. (Needed to be able to install Demo Templates on the machine)
    2. Demo Templates for R2 SP1.
    3. EPiServer CMS R2 SP2.
  2. Install an SP2 site.
  3. Select Install Demo Templates for SP1 (found under the SP1 node in the tree (5.2.375.133)).
  4. In the next step you will be asked which features of the Demo Templates to install.
  5. You will now be prompted to select a site where to install the module but you won’t find your SP2 site.
  6. Select the brand new Show All Sites checkbox in the upper right corner of the wizard.
    image
  7. After a small alert, all sites on the local IIS will be shown and you can select the SP2 site you just created.
  8. Go ahead and complete the wizard.
  9. Your done!

I tested the above steps to install composer Composer 3.2.5 for SP1 as well but did not manage to get it working completely. I can’t really tell if it is me or it actually is something that needs to be updated for CMS 5 R2 SP2 to work. Composer experts go ahead and try yourself and feel free to comment on this post.

Jun 25, 2009

Yiming Zeng
(By Yiming Zeng, 9/21/2010 12:32:35 PM)

Hi Fredrik,

I cannot find the Show All Sites checkbox. Could you enlight me on this please?

Thanks,
Yiming

fredrik.tjarnberg
(By fredrik.tjarnberg, 9/21/2010 12:32:35 PM)

After installing CMS 5 R2 SP2 or later (CMS 6.0 RC1) on a machine, Deployment Center should have been upgraded to have this check box in its select site wizard step. What version do you have?

Please login to comment.