Views: 10460
Number of votes: 1
Average rating:

EPiServer/SharePoint Videos Part #1

UPDATE: added new videos and re-recorded and re-encoded all videos as hi-res and optimised for smaller file size

I have been busy recording a series of videos demonstrating the capability of the EPiServer Connector for SharePoint. They are now ready – please take a look and use them / review them for me! I am hoping to sort out a streaming media host, but until then I've produced them as compact Windows Media files so that they can be downloaded in full. They are recorded at 1024x768 so you will get the best from them if you view them in a large window or full-screen.

EPiServer Connect for SharePoint Demo 1 (6 Mb)

  • Pulling documents into EPiServer Edit Mode from SharePoint
  • Pulling images into EPiServer Edit Mode from SharePoint
  • Using SharePoint documents on an EPiServer page
  • Pushing documents back up to SharePoint from EPiServer

EPiServer Connect for SharePoint Demo 2 (3 Mb)

  • Enabling end users to browse a SharePoint site

EPiServer Connect for SharePoint Demo 3 ( 6 Mb)

  • Using a Content Channel to publish SharePoint Tasks as EPiServer Pages
  • Updating settings on a Content Channel
  • Pushing updated content through a Content Channel from SharePoint

EPiServer Connect for SharePoint Demo 4 (7 Mb)

  • Pulling EPiServer pages into SharePoint using the Connector Web Parts

EPiServer Connect for SharePoint Demo 5 (10 Mb)

  • Pulling content from the Northwind Custom Page Provider
  • Updating content using the Northwind Custom Page Provider
  • Pulling the Northwind content into SharePoint using the Connector Web Parts

EPiServer Connect for SharePoint Demo 6 (7Mb)

  • Viewing MOSS Publising webs and pages in EPiServer using a Custom Page Provider
  • Updating MOSS Publishing content from EPiServer using a Custom Page Provider
  • Viewing MOSS Publishing content in a MOSS Team Site via EPiServer Web Parts and a Custom Page Provider

If there is anything you think I should be covering or I could improve in my sessions, please please do let me know.

NOTE: I have removed the old Indeo-compressed AVI movies as the new ones are far better quality.

Jun 24, 2009

pb
(By pb, 9/21/2010 12:32:34 PM)

I guess you need some special codec to watch the videos, it won't play on my Vista machine in either Media Player or VLC - I only hear the sound but no video.

dan.matthews
(By dan.matthews, 9/21/2010 12:32:34 PM)

Intel Indeo 4.5 codec... I thought this was fairly common but you may need to get it off the Web :)

(By , 9/21/2010 12:32:34 PM)

Vista doesn't have Indeo codec per default, I believe. Running the videos on XP works like a charm however. Seems interesting, thanks Dan.

dan.matthews
(By dan.matthews, 9/21/2010 12:32:34 PM)

Fredrik - I think you're absolutely right. However, I've re-encoded them all as WMV files which don't need Indeo, so they will all play on XP or Vista now :)

(By , 9/21/2010 12:32:34 PM)

Ye, I saw your note at the bottom just after sending the message. It's a good thing that I never feel stupid, or not... :)

Guest
(By Guest, 9/21/2010 12:32:34 PM)

Hi Dan,
Just playing with Connector for Sharepoint, and I'm just wondering how you configure the systems to enable a two way exchange? I have the documents pulling in from MOSS, but if I add a folder/file (like in your video), they don't appear in the MOSS location

Thanks

P.S. I'm loving you're videos, they are really informative!
/ Richard Hayes

dan.matthews
(By dan.matthews, 9/21/2010 12:32:34 PM)

Richard - the 2-way communication should work automatically. I certainly didn't have to configure anything additional for it. Maybe it's a permission issue? Maybe double-check that you've run through all the installation steps correctly and are using a user with appropriate permissions on your MOSS/WSS installation?

Guest
(By Guest, 9/21/2010 12:32:34 PM)

Thanks Dan. Can I just clarify something. In order to see Sharepoint content in the File Manager, do you have to (once all is installed):

A. Create a content channel and map its virtual root to something like "~/Global", rather than the "SharePoint" VirtualPathWSSProvider

or

B. Just map it to the WSS VirtualPathWSSProvider and all should be well?

Thanks
/ Richard Hayes

dan.matthews
(By dan.matthews, 9/21/2010 12:32:34 PM)

Richard - the answer is B, but let me explain a little more. Seeing content in the SharePoint starting point in File Manager is nothing to do with Content Channels - don't mix up the two ideas :)

If you want a 2-way sharing of files (documents, pictures etc.) between SharePoint and EPiServer, set up the connector to point at the SharePoint site you want to share. This will use the WSS virtual path provider to enable you to work with the SharePoint libraries in that site as if they were in EPiServer - just look in the SharePoint starting point in File Manager.

The one drawback to this method is that everything in your SharePoint libraries has to be treated like a file. If you want to pull some of those items back as EPiServer PAGES, that's when you use a Content Channel.

So, for example, if you want to pull some tasks out of a SharePoint task list and display them as EPiServer pages, you would use a content channel to push the tasks through to EPiServer as pages. The 'receive' end of the channel would define what page on the site is the container for the new pages. Note that you do also set a path for FILES, but that is more to do with files/attachments which get pulled through the channel as well, and determines where they go.

The big consideration with content channels is that they are only 1-way. They are effectively like a very powerful and flexible import. They are ideal for pages but not really designed for files.

I hope that makes sense :)

Guest
(By Guest, 9/21/2010 12:32:34 PM)

Clear as crystal Dan! Have solved my problem!

I was under the impression you had to use content channels for all SP data, hence why I wasn't able to perform a two-way communication!

The whole reason I was using content channels to serve files in the first place was when I attempted "B", it wasn't working dispite trying everything.

I have literally just uncovered that this problem was due to IT not putting the user in the correct group :-).

Thanks again for your help its been most valuable!


/ Richard Hayes

(By , 9/21/2010 12:32:35 PM)

Great! What kind of Sharepoint licenses do you need from Microsoft for publishing information from Sharepoint to your public web site through the 2-way connector?

dan.matthews
(By dan.matthews, 9/21/2010 12:32:35 PM)

@Sami - that's a question for Microsoft, but there is a certainly scope for being creative in license situations like this! :)

Please login to comment.