EPiServer CMO 2.1 PageTree issue in LPO-test

Member since: 2003

I have just set up EPiServer CMO 2.1. on an upgraded EPiServer 6 R2 site.

In both development and test i get an annoying "Object reference not set to an instance of an object." error when clicking the page-selector for "orlginal page" or "Conversion page" and trying to expand a node in the tree-structure. I have been over the setup several times without finding an explanation or solution to this problem. 

Anyone else have experienced similar problems, or got an idea to what can be the cause of this problem? Appears to be a configuration issue, but I am a little ouot of ideas.

.Net Framework 3.5 (not 4), runs ono Win7 (dev) and 2003 Server (test)

#54476 Oct 18, 2011 15:46
  • Member since: 2008

    I'm trying to reproduce this issue by installing CMO 2.1 on site which was upgraded from CMS 6 to CMS 6 R2. Is it your case?

    Do you have any exception details, like stack trace?

    #54477 Oct 18, 2011 16:22
  • Member since: 2003

    Yep. That is my case :-)

    No stack trace is generated unfortunately, seems to be captured within the ajax post or something.

    I have tryed to attach to the script and debug, but no success so far.

    #54478 Oct 18, 2011 16:34
  • Member since: 2008

    Hello Lars,

    Please, check the web.config if you have this handler in /configuration/system.webServer/handlers:

    <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" preCondition="integratedMode" />    
    and this module in /configuration/system.webServer/modules:
    <add name="ScriptModule" preCondition="managedHandler"
             type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    #54484 Edited, Oct 18, 2011 22:08
  • Member since: 2003

    Thanx for the tip. Wil try this tomorrow and let you know.

    Seems likely that this is some sort of configuration issue, as i tried to install a clean installation of CMO directly on e fresh 6 R2-site, and there the pagtree works fine.

    #54486 Oct 18, 2011 22:11
  • Member since: 2003

    They are both present in my config file. The error still remains unfortunately. Did a diff on the config files from a working site and made some adjustments, but still the same null-reference error...

    #54514 Edited, Oct 19, 2011 9:32
  • Member since: 2008

    I cannot reproduce this issue on upgraded sites both with Public and Demo/Alloy templates. It is possible to select original and conversion pages in LPO test settings.

    Try to turn on logging on site and see if you get any error in log. You can add debug output or file appender and enable Debug level logging for site. Example configuration in EPiServerLog.config file:

    <?xml version="1.0" encoding="utf-8"?>
      <appender name="OutputDebugStringAppender" type="log4net.Appender.OutputDebugStringAppender">
        <layout type="log4net.Layout.PatternLayout">
          <conversionPattern value="%date [%thread] %-5level %type.%method - %message%newline" />
        <level value="Debug" />
        <appender-ref ref="OutputDebugStringAppender" />


    DebugView is nice tool to read logs for debug purposes. You can also try to find any related error in Windows Event Viewer.

    Probably the issue is related to your specific site and how it is upgraded to last CMS version. Do you use any special data source/page provider?

    You can also check section "Issues When Upgrading from EPiServer CMS 6" in following document: http://world.episerver.com/Documentation/Items/Installation-Instructions/EPiServer-CMS/Version-6/EPiServer-CMS-6-R2/Installation-Instructions---EPiServer-CMS-6-R2/#upgradeissues

    #54517 Oct 19, 2011 10:27
  • Member since: 2008

    ... and one more option how you can try to catch exception: try to reproduce the issue in Firefox with FireBug. Make sure that console and network monitoring are enabled and you get all messanes/activity in that tabs.

    Try to reproduce the problem and check if you have some information in FireBug console.

    Check also all network requests and check response data and html if there is any errors (typically response with code 5XX or 4XX).

    #54520 Oct 19, 2011 12:10
  • Member since: 2003

    The only error logged that may be the cause of the problem is this:

    ERROR [5] EPiServer.DataAbstraction.LanguageBranch.get_ResolvedIconPath - Could not resolve language icon path: util/images/flags/flag_no.gif
    EPiServer.Core.EPiServerException: Can't resolve non-rooted path 'util/images/flags/flag_no.gif'
       at EPiServer.UriSupport.ResolveUrlBySettings(String path)
       at EPiServer.DataAbstraction.LanguageBranch.get_ResolvedIconPath()

    I tried to add te image in question to both the global EPiServer Util/[....]/images path, as well as a local folder under /util/images/flags, bus still no cake for me...

    #54525 Oct 19, 2011 14:04
  • Member since: 2003

    Another fun-fact: The page-picker works excellent under "Campaigns". It both expands and collapses just fine there. It is only under LPO it is acting out.

    A bit strange as it is the exact same strukture that feeds the pageTree as far as I can see... Maybe different scripts?

    #54529 Oct 19, 2011 15:18
  • Member since: 2008

    Does page selector work fine both when you create campaign for all languages and when you create campaign for specific language?

    Did you managed to get more information on client side using FireBug?

    #54533 Oct 19, 2011 16:02
First   1 2   Last