Button for inserting/edit link sometimes dissapear in TinyMCE?

Member since: 2005

We are using EPiServer 6 R2 and have a strange problem.
The button in toolbar for inserting/editing link (the one with a globe) sometimes dissapear from toolbar,  for several editors.

I have never encountered the problem myself but some editors explained the problem to me.
No changes are made to the "default" settings of the editor.

We can not recreate the problem in any managed way.

Is this a known issue or has someone else reported a problem like this?


#54009 Sep 29, 2011 9:23
  • Sorry, I haven't heard of this problem. It disappears randomly? Or is it always missing for some of the editors?

    #54396 Oct 13, 2011 8:54
  • We have the same problem in one of our sites after upgrading to R2. The link button is missing and also the browse for file button in the insert image dialog.

    It seems to affect IE7, IE8 and IE9 32-bit version. The problem is solved in IE9 by hitting Ctrl+F5 in the 64-bit version. Then both versions work.

    Have not found a solution for IE7 or IE8. The problem has also been seen in Chrome and Safari. Firefox works fine.



    #54584 Oct 21, 2011 22:07
  • Member since: 2005

    I've found out now that some of our editors are using Firefox! When they changed browser to IE9 it worked again?!

    But we also had problems with IE9, I will try Ctrl +F5 next time.

    It's not always the same user and it dissapears randomly...


    #54611 Oct 24, 2011 14:41
  • Got it! Changing the DNS record from CNAME (Alias) to A-record solved the problem.

    #54777 Nov 02, 2011 13:40
  • Member since: 2008

    Geir: Did you ever find out WHY changing the DNS record solved the problem?

    #55842 Dec 20, 2011 10:14
  • I've encountered this problem too and in addition to the link button, also the dynamic content button is missing for the editors having problems.

    I haven't been able to test with the DNS record modification yet, but hopefully that will solve it. In the meantime, did anyone find out anything more about this?

    #57824 Mar 29, 2012 9:38
  • Member since: 2008

    Could try this, which partner sent in for a similar problem (windows auth)
            <deny users="?" />

    in <location path="util">

    #57850 Mar 30, 2012 13:58
  • Thanks, Paul. It turns out however, that the DNS change seems to help at least a few of the editors (haven't confirmed with all). However, the buttons now disappeared for those who had them before... Clearing the browser cache seems to fix that problem though, so I guess something happened in the scripts when the DNS change was made.

    #57852 Mar 30, 2012 14:05
  • Member since: 2000

    I also had som difficulties with this but can confirm that Pauls solution works - at least i did for me. I used "allow roles" but the effect was the same

    The problem was that it worked intermittently for us. We finally identified this as having to do with the fact that an administrator *had* been logged into EPiServer on the same client. Somehow it was cached and when the cache expired it stopped working.

    #57853 Mar 30, 2012 14:22
  • I have experienced the same problem on our intranet site after upgrading from 6 to 6R2. The site uses windows authentication. Neither of the solutions mentioned in earlier posts have worked, has anyone found another solution to this problem?

    #59082 Edited, May 19, 2012 9:25
First   1 2   Last