Drag and Drop in FileManager fails

 

Hi!

My customer really needs to be able to drag and drop multiple files from windows explorer to EPiServer FileManager, but it doesn´t work. I get the error Uppladdningen misslyckades med felkod [500]. I have installed version 2.3 of EPiServer Client Components on the client machine and restarted it but the problem remains. Have i missed something? Anyone has a solution?

#30295 Jun 11, 2009 10:37
  • Member since: 2002
     

    Have you applied the correct access rights in admin mode?

    Admin mode -> config tab ->  Permissions for functions
    Make sure that the users have access to the "Allow advanced upload of files using...."

    Can't see how that would generate a 500 error, but always start with the easiest solutions :-) 

    #30328 Jun 11, 2009 16:08
  •  
    Yes, i have tried both adding groups and users to the "Allow advanced upload of files using....". What does the 500 error mean technically?
    #30333 Jun 11, 2009 16:42
  • Member since: 2002
     

    500 is the Internal server error message. See a list of the different error codes at:
    http://en.wikipedia.org/wiki/List_of_HTTP_status_codes#5xx_Server_Error  

    Do you have any logging on the server? It would be great to have some more information....

    Have you tried the suggestions from this thread?:
    http://world.episerver.com/Forum/Pages/thread.aspx?id=15991

    And the blog entry "Office 2007 Mime Types (for IIS)" at http://www.epinova.no/no/Blog/episerver_blog/ 

    #30334 Jun 11, 2009 16:49
  • Member since: 2008
     

    Hi Tobias,

    If you are using virtualPathNativeProvider then we have a registered bug against this issue which has already been fixed and will be shiped with SP2 release.  Here is bug id: Bug # 22493.

    Sometimes when you do drag and drop having multiple files, it does upload 1 file and then returns error code 500.

    Regards,

    Shahid
    EPiServer Support Team

    #30336 Jun 11, 2009 17:27
  •  

    Thanx but I found the cause myself. I use a theme-folder in which I have put the websites css-files. To be able to do that all the webpages need to have a head tag with the runat="server" attribute set. That is not the case with the episerver-pages in the OfficeIntegration-folder, the same goes for the pages in the EPiServerMail-folder. That causes the following runtime error(in the page /OfficeIntegration/HandleMultiUpload.aspx):

    Server Error in '/' Application.
    Using themed css files requires a header control on the page. (e.g. <head runat="server" />).

    The solution is to disable themes for the OfficeIntegration-folder in web.config, like this:

    <location path="sec/OfficeIntegration">
        <system.web>
          <pages theme=""/>
          <authorization>
            <allow users="*" />
          </authorization>
        </system.web>
      </location>

    The same goes for the EPiServerMail-folder:
    <location path="EPiServerMail">
        <system.web>
          <pages theme=""/>
          <authorization>
            <deny users="?" />
          </authorization>
        </system.web>
      </location>

     

     

    #30337 Jun 11, 2009 17:39