Parameter has no page set Parameter name: pageLink

Member since: 2009
 
 

Hello everyone!

 

I get the following error message when I am adding new pages or any other command in Edit mode, I have read a post stating that this was an issue that should have been solved in SP1, I am running version 5.2.375.133 on Windows vista SP1. Any help would be greatly appreciated, if any further information is needed please let me know.

 

Best regards

/Niklas Johansson

 

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentNullException: Parameter has no page set
Parameter name: pageLink

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

 

[ArgumentNullException: Parameter has no page set

Parameter name: pageLink]

   EPiServer.DataFactory.GetChildren(PageReference pageLink, ILanguageSelector selector, Int32 startIndex, Int32 maxRows) +335

   EPiServer.DataFactory.GetChildren(PageReference pageLink, ILanguageSelector selector) +12

   Dropit.Extension.Controllers.ContainerManager.GetShadowPage(PageReference containerPageLink, PageReference pageLink) +119

   Dropit.Extension.Controllers.ContainerManager.GetSiteRootContainer(PageReference startPage) +125

   Dropit.Extension.Controllers.ContainerManager.GetTemplateContainer(PageReference startPage) +118

   Dropit.Extension.Controllers.TemplateManager.List() +60

   Dropit.Extension.Controllers.TemplateManager.List(Boolean visibleInMenu) +40

   Dropit.Extension.Controllers.TemplateManager.ListAllowedTemplates(PageReference pageLink) +91

   Dropit.Extension.UI.Edit.ExtensionNewPage.OnLoad(EventArgs e) +176

   System.Web.UI.Control.LoadRecursive() +50

   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627

#30021 May 27, 2009 9:55
  • Member since: 2010
     
    You need to try and debug the static controls that are included on this to see which page is giving you the problem. As an outside guess, I'd say that you have deleted an important property somewhere.  This is the only way I can see you getting this kind of message.
    #30029 May 27, 2009 13:05
  • Member since: 2009
     

    Thanks for the answer!

     I installed EPiServer again and now everything works perfectly.

     Best regards

    /Niklas

    #30102 Jun 02, 2009 10:49
  •  

    Hi ,

             When i try to access the page the following error is throwing 1.parameter has no pageset 2. parameter name:page Link. and the error is showing in PageBase.cs file.

     

     

    Can any one pls figure out this issue? Thanks in advance.

     

    Regards,

    Murali Krishna.

     

    #57064 Feb 23, 2012 12:55
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply