Disabling the Not Published List

Member since: 2009
 

We have a large number of pages that are only used for Data management (we're talking 100s of thousands) generated by a tool. Is there a way to disable the "Not Published" List on the edit mode "Welcome to Episerver" front page as the database hit for each one is causing a large delay in loading it.

 

Cheers

#29661 May 07, 2009 19:06
  • Member since: 2001
     

    I asume this is a EPiServer CMS 5 website. If it is you can create your own replacement for the page "/systemui/edit/workspace.aspx" and maybe even the page "/systemui/edit/EditTree.aspx". Use a reflection tool and override the EPiServer class or create your own version of these pages where you disable the functionality for the Not Published List.

    After this is done you have to make som additions to web.config.

    First add the <virtualPathMappings> segment to the <episerver> section. Like this:

    <virtualPathMappings>
    <add url="~/systemui/edit/workspace.aspx" mappedUrl="~/OwnUI/edit/workspace.aspx" />
    <add url="~/systemui/edit/edittree.aspx" mappedUrl="~/OwnUI/edit/edittree.aspx" />
    </virtualPathMappings>

    Secondly you must add (if it not already exist) a VirtualPathMappedProvider to the collection of VitrualPathProviders and place it as the last VPP, like this:

    <add virtualName="ExtensionMapping" virtualPath="~/SystemUI/edit" bypassAccessCheck="false" showInFileManager="false" name="EPiServerUrlMappingVPP" type="EPiServer.Web.Hosting.VirtualPathMappedProvider,EPiServer" />

    I hope this will help you.
    /Peter 

     

    #29665 Edited, May 08, 2009 7:55
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply