Problem upgrading from epi5 sp1 to epi5 sp3 | Episerver Developer Community

Problem upgrading from epi5 sp1 to epi5 sp3

 

Upgrade process went pretty smoothly but now I get this error when I try to go to the admin. Can anyone help?:

Server Error in '/' Application.
Failed to load some types from "XmlPageProvider": Could not load type 'EPiServer.Security.ISecurityDescriptor' from assembly 'EPiServer.BaseLibrary, Version=5.1.422.267, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'. Could not load type 'EPiServer.Core.PageProviderBase' from assembly 'EPiServer, Version=5.1.422.267, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: EPiServer.PlugIn.PlugInException: Failed to load some types from "XmlPageProvider": Could not load type 'EPiServer.Security.ISecurityDescriptor' from assembly 'EPiServer.BaseLibrary, Version=5.1.422.267, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'. Could not load type 'EPiServer.Core.PageProviderBase' from assembly 'EPiServer, Version=5.1.422.267, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[PlugInException: Failed to load some types from "XmlPageProvider": Could not load type 'EPiServer.Security.ISecurityDescriptor' from assembly 'EPiServer.BaseLibrary, Version=5.1.422.267, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'. Could not load type 'EPiServer.Core.PageProviderBase' from assembly 'EPiServer, Version=5.1.422.267, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'. ]
EPiServer.PlugIn.AssemblyTypeInfo.GetTypes() +299
EPiServer.PlugIn.AssemblyTypeInfo.ScanAssembly() +164
EPiServer.PlugIn.PlugInLocator.get_Assemblies() +419
EPiServer.PlugIn.PlugInLocator.FindPlugInAttributes() +68
EPiServer.PlugIn.PlugInRuntime.Start() +11
EPiServer.Global.StaticInitialization() +71
EPiServer.Global.Global_BeginRequest(Object sender, EventArgs e) +125
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +68
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75


Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082

 

#29480 Apr 28, 2009 16:50
  • Member since: 2005
     

    Hi!

    Easiest solution, if you don't use it, is to just remove the file XmlPageProvider.dll from your bin folder.

    The XmlPageProvider is just a sample implementation of a custom page provider, and not used internally by EPiServer CMS.

    Regards

    Per Gunsarfs
    EPiServer CMS development team

    #29481 Apr 28, 2009 17:11
  •  
    Wonderful! That worked a treat!
    #29482 Apr 28, 2009 18:11