Error exporting Page types

 

Hi,

I get an errormessage when I try to export page types. This is the error I get:

The following errors have occurred:
Exception: There was an error generating the XML document.[Instance validation error: '268435455' is not a valid value for EPiServer.Editor.EditorToolOption.]

 

Any suggestions är welcome.

Best Regards,
Marcus

#29125 Apr 08, 2009 9:48
  • Member since: 2007
     
    Hmm, what value is set for the editor(s) (xhtml strings) on that page type?
    #29126 Apr 08, 2009 10:35
  • Member since: 2003
     

    Funnily enough we got the same problem here today... :-) The same error message with the same number serie when we try to export page types.

    What I found out is that in table PageDefinition in the DB the number in the error message is found in the column 'LongStringSettings' for a lot of the properties. Some properties who have this number is not a xhtml-string. What is this number anyway?

    The system where we get the error is a EPi5 R1 sp3, which was upgraded from a EPi4 system. Has something happened during that process maybe? The problem is only visible for old page types from the original EPi4 system, or new page types copied from an old page type. If I create an enirely new page type it all works normally.

    /Mikael

    #29134 Apr 08, 2009 15:00
  • Member since: 2008
     

    Hi Mikael and Marcus,

    Seen this issue before. Usually it's a upgraded site or some pages that got imported from another site.

    What the number for EditorToolOption shows are the settings for your editor. For example if you want to show the bold button or not. What has worked for everyone I have helped so fare is to resave the pagetype thus updating the settings in the database.

    #29136 Apr 08, 2009 15:30
  • Member since: 2003
     

    Hi Petter!

    I have tried to first resave all the properties in the page type and then save the page type itself, but the error remains.

    I also have properties in the page type that are not xhtml-strings, but still have this number sequence, corresponding to the choices of editor options, in DB. Shouldn't the value for these non-xhtmlstring properties be more like -1 in the DB? Doesn't seem to make sense...

    /Mikael

    #29142 Apr 08, 2009 16:55
  •  

    Hi

    This solves the problem.You need to re-save all properties with too high value on LongStringSettings, not just the pages. Some properties get non valid values during the migration process for some reason.

    Run this query on your episerver database to see which properties to re-save. Then re-save them in admin mode.
     
    SELECT     tblPageDefinition.pkID, fkPageTypeID, tblPageType.Name, tblPageDefinition.Name, LongStringSettings
    FROM         tblPageDefinition, tblPageType
    WHERE tblPageType.pkID = tblPageDefinition.fkPageTypeID
    ORDER BY LongStringSettings DESC


    //Marcus

    #29693 May 08, 2009 15:03
  • Member since: 2003
     

    Petter/Greger - did you find a workaround for this issue?

    I have the same problem on a migrated site where resaving the properties and pages is not an option - I have almost 100 pagetypes and up to 500 000 EPiServer pages in the database.

    (Saving just the pagetypes doesn't help)

    I assume this is a bug in the Migration Tool - since LongStringSetting 268435455 doesn't exist in cms 5.

    #33481 Oct 14, 2009 12:18
  • Member since: 2006
     

    Mari,

    It's not enought to just save the PageTpe, you'll have to resave all the longstring/xhtml properties on all pagetypes that has this error :-(

    Can't remember if we made a script to do changes in the database or if we made a webpage that did the propertysaving.

    We are looking to see if anyone of us here can remeber what we did before the summer vacation ;-)

    //Morten

    #33497 Oct 14, 2009 16:03
  • Member since: 2003
     

    Hi,

    I solved my problems with this issue by querying the DB which properties had this number on LongStringSetting and then simply replacing the '268435455' with a -1 (or whatever the default setting for non longstrings is) directly in the DB. As the properties was not of XhtmlString/LongString type it seemed safe enough as I wouldn't replace any existing settings.

    /Mikael

    #33506 Oct 14, 2009 17:26
  • Member since: 2008
     

    Hi,

    Below mentioned solution worked for me.

    To resolve this error you need to execute the following queries in your migrated website database:-

    DECLARE @PageDefinitionTypeID INT

    SELECT @PageDefinitionTypeID  = pkID FROM tblPageDefinitionType WHERE Name LIKE 'xhtmlString'

    PRINT @PageDefinitionTypeID

    UPDATE tblPageDefinition SET LongStringSettings = -1 WHERE fkPageDefinitionTypeID <> @PageDefinitionTypeID
    GO

    UPDATE tblPageDefinition SET LongStringSettings = 4194295 WHERE fkPageDefinitionTypeID = @PageDefinitionTypeID
    GO

    /Pankaj

    #35262 Dec 02, 2009 6:50
  •  

    Can anyone verify that the above SQL is SAFE to execute in production for our CMS 5 R2 SP 2 based site?

    /Christer

    #44246 Oct 07, 2010 9:57
First   1 2   Last 
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply