Office add-in creates blank pages

 

I'm trying to publish documents from Word 2007 to an EPiServer 5 website. I type the content into Word, save the file as a .doc file, and click Publish to EPiServer. Everything works until I see a preview of the page that has been created on the website. It's blank!

After 2 hours of searching through EPiServer world I finally figured out that the office add-in is trying to put my page content into a page property called MainBody. And, as in my case, if your pages don't have a property called MainBody, the office add-in simply creates a blank page for you.

Please let me know if there is a way that I can configure this behaviour.

#28646 Mar 17, 2009 12:47
  •  
    Hi. I think you can configure this with help from tech note on office integration.
    #28652 Mar 17, 2009 14:10
  •  

    Thanks Cristian. The customisation section had the information I was after.

    For anyone else who is not sure what to do... I had to add an episerverModules section to web.config to override the default configuration.

    <episerverModules>

    <officeIntegration>

    <filters>

    <filter pageTypes="*" extensions="*" src="WordHtml.config" />

    </filters>

    <wizards>

    <wizard pageTypes="21,22" extensions="xls,doc,docx" src="MyConfigFile.config" />

    <wizard pageTypes="*" extensions="*" src="Default.config" />

    </wizards>

    <scripts>

    <script pageTypes="*" extensions="doc,docx" src="EPiServer.Word.wsc" />

    <script pageTypes="*" extensions="xls,xlsx" src="EPiServer.Excel.wsc" />

    <script pageTypes="*" extensions="ppt,pptx" src="EPiServer.PowerPoint.wsc" />

    </scripts>

    </officeIntegration>

    </episerverModules>

    I added a new wizard section. Notice the property pageTypes refers to page type IDs. Hover the mouse over a page type in admin mode to see the page ID in the URL.

    I also had to create a separate config file and place it in UI/OfficeIntegration/wizard/. The xml is below. Notice the targetProperty is my own (default is MainBody).

    <?xml version="1.0" encoding="utf-8" ?>

    <wizard name="Default" targetProperty="MainContent">

    <step name="MetaData" title="Meta data">

    <property name="PageName" />

    <property name="PageStartPublish" />

    <property name="PageStopPublish" />

    <property name="MainIntro" />

    </step>

    <step name="Done" title="Done" customcontrol="./Done.ascx" />

    </wizard> 

    #28682 Mar 18, 2009 11:00