MultiSite and ASP.NET Development Server (Cassini)

 

We have an EpiServer configuration, that has multiple sites.

We want to use the ASP.NET Development Server that comes with the VS.NET 2008 install.

There are two issues that are stopping this from being an an ideal setup

  1. Root access to a site does not work. The root of the site is setup to redirect to the Home page configured in the site. However when you request http://localhost:8080/ the site is displayed with no content, rather than the content for http://localhost:8080/en/Home. Going direct to the Home page works fine
  2. Multiple sites configured in the config, yet the first site is always teh one served. For example if 3 sites are configured, each with a different site hosts entry, <add name="localhost:2257" />, <add name="localhost:5714" />, <add name="localhost:3737" />. No matter what port number is used the site served by EpiServer will always be the first one on the file. It is as if it sees localhost in the confif and ignores the port number. Is this expected behaviour?

Anyone have answers to these issues

 

TIA

 

Pat Long

 

#28238 Feb 26, 2009 19:24
  • Member since: 2006
     

    Hi,

    I'm having the same problems, in addition there also seems to be a problem with getting to edit and admin mode when running through Cassini. I've tested my site running through IIS, but when running through Cassini on localhost:port I get a 404 error when trying to get to [path]/edit/default.aspx, or [path]/admin/default.aspx. 

    There's nothing in the event logs to indicate waht's going on, in addition when i browse to[path]/ i get a directory listing of the folders in that root which lists edit and admin as directories within there.

    Has anyone else had the same problem, or has their development site(s) running through Cassini successfully?

    Thanks

    Graeme

    #28298 Mar 02, 2009 13:01