Installing a module with 5.2 SP1

Member since: 2006
 

I've created a zip file module and added an epidata export to utils/setup.

When I use this module with Deployment Centre to update a new site I get an error below.  Anyone now what might be wrong?  I'm guess it might be becuase the export file contains pages and I was not asked to specify the root page for importing them.

Thanks

Importing Util\setup\ExportedFile.episerverdata
An error has occured and the transaction will be rolled back
Rolledback

An unhandled error has occured:
Exception: Parameter has no page set
Parameter name: pageLink[]
When executing


At C:\Program Files\EPiServer\CMS\5.2.375.133\Install\System Scripts\Install ZI
P Module.ps1:130 char:20
+ Add-EPiServerData <<<< -ImportSource $importFilePath `

Error - System.Management.Automation.CmdletInvocationException: A bulk installation has not been started ---> System.ApplicationException: A bulk installation has not been started
at EPiServer.Install.InstallationManager.RollbackBulkInstall()
at EPiServer.Install.Common.Cmdlets.RollbackBulkInstallCmdlet.ProcessRecord()
at System.Management.Automation.Cmdlet.DoProcessRecord()
at System.Management.Automation.CommandProcessor.ProcessRecord()
--- End of inner exception stack trace ---
at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
at System.Management.Automation.Parser.PipelineNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)
at System.Management.Automation.Parser.StatementListNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)

 

#27887 Feb 12, 2009 3:15
  • Member since: 1999
     
    The ZIP-installer assumes the site has a start page, thats where it will import the pages. Does the site have a start page ?
    #27907 Feb 12, 2009 15:54