Episerver Migration Wizard - error when attempting to select the web.config files

 

When openning the Episerver Migration Wizard to migrate my 4.62 project to 5r2 I am asked to:

Please select the web.config files used by the source and destination sites.

I can select both web.config files from my c: however when clicking next, I get the below error:

 

---------------------------
Validation error
---------------------------
Validation of configuration files failed.

General errors:

Validation failed: Method failed with unexpected error code 3.

 

 Any help would be greatly appreciated. I've spent hours searching for an answer, with no luck!

#27299 Jan 23, 2009 18:20
  • Member since: 2007
     
    is the 5r2 web.config a clean web.config? i.e installed from a fresh epi 5r2
    #27310 Jan 26, 2009 15:20
  •  

    yes, its a fresh install form epi5r2.

    At a guess I'd say it would have to be something within my 4.62 config file - however the error message i recieve does not descibe what may be wrong...

    #27312 Jan 26, 2009 15:50
  • Member since: 2007
     

    well. I would make sure to have:

    * Given rights to the upload vpp folder

    * make sure that the path there is correct

    * Given rights to your old upload folder

    * make sure that the path to that one is also correct

     

    Try that and see if it works.  If you've tried that already then its atleast one thing you dont have to worry about :)

    #27315 Jan 26, 2009 16:02
  •  

    I've checked the above and the permissions on the upload folders and paths to the config files are correct - just to make sure, I've been back into both the 4.62 installation and 5r2 installation and uploaded files through edit mode

    any other ideas?

     

    #27327 Edited, Jan 26, 2009 18:31
  • Member since: 2007
     

    Are you upgrading from the same machine where both the sites are installed and running?

    If not, then that is your problem. For the migration tool to work, you need to run it on the server that runs the pages. i.e both sites must be accesable at the same time from the same machine where you are running the migration tool

    #27339 Jan 27, 2009 10:22
  •  

    yep, same machine (both on c:) with a local instance of SQL2005 installed.

    Both sites are running and are accessable at the same time (I've created a virtual directory for both sites under the Default Website)

    There doesn't seem to be any doccumentation about this type of error!

    Does anyone have an error code sheet?

     

     

    #27368 Jan 27, 2009 14:19
  • Member since: 2004
     

    Hmm, It is no error thrown directly from Migration tool. It must be some .NET framework code (called from Migration tool) that throws that exception.

    Do you run Windows Vista? If that is the case, make sure the Migration Tool is run as administrator. In later builds Migration Tool automatically does the elevation but if you have some previous build that might not be the case.

    #27613 Feb 04, 2009 12:50
  •  

    Thanks for your help - The above problem was being caused by incorect paths within the config tags, causing the .NET framework to throw the error 3 message! It took a while, but after alot of trail and error I can now run the migration tool.

    #27985 Edited, Feb 16, 2009 15:28
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply