Subscribers after migrating to CMS5 R2

Member since: 2003
 

I have migrated a site from 4.62 to CMS 5 R2 and almost everything works fine!

The customer has a weekly newsletter which has over 300 subscibers. They wanted to convert the newsletter to a Blogg type. I convert the newsletter pagetype to a grupp blogg. It went well, but when I now try to add a blogg page, I get an exception:

Exception Details: System.ArgumentNullException: Parameter has no page set
Parameter name: pageLink

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[ArgumentNullException: Parameter has no page set Parameter name: pageLink]    EPiServer.DataFactory.GetPage(PageReference pageLink, ILanguageSelector selector) +243    EPiServer.Blog.EventHandlers.GetDatePageRef(PageReference dateContainerRef, DateTime published) +60    EPiServer.Blog.EventHandlers.CreatingPage(Object sender, PageEventArgs e) +430 

No problem. I have an another blogg that is working. I just want to move every subscribers to that blogg. How to do that???

I tried to find the subscribers at the database. I subscribed myself some pages and found myself in the dbo.aspnet_Profile table. But I'm the only subscriber there... Where are the others? Did the migration tool miss them?

So... can't I convert a "normal page" to a "group blogg start" AND where are the subscribers and how to move them?

 

#26525 Dec 09, 2008 23:49
  • Member since: 1999
     

    Which version of the Migration Tool did you use ?

     

    #26546 Dec 10, 2008 15:59
  • Member since: 2003
     
    It was 1.1.0.21 (2008-11-07)
    #26548 Dec 10, 2008 17:07
  • Member since: 1999
     

    Ok, that version should convert subscriptions as far as I know. It was the release candidate (RC) that did not convert subscriptions.

    They are stored in the tblUserProperty table in your EPiServer 4 database (together with other personalization data). Can you find your data over there ?

     

    #26549 Dec 10, 2008 17:50
  • Member since: 2003
     

    Yes, the subscriptions are there in the tblUserProperty. By linking the tblUserProperty with tblUser using fkSID i can print out every over 400 subscribers and their subscriptions.

    When I look at one subscriber who has 2 newsletter subscribed at EPiServer 4 database, I find him also in EPiServer CMS5 database, at the dbo.aspnet_Profile table in the PropertyValuesString field with the following text:

    "SUBSCRIBERS NAME"
    <?xml version="1.0" encoding="utf-16"?>
    <SubscriptionInfo xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">   
    <SubscribedPages />
    <LastMessage>2008-12-10T19:53:58.875+01:00</LastMessage>   
    <Interval>0</Interval> 
    </SubscriptionInfo>
    "SUBSCRIBERS EMAIL + ADDRESS"

    It seems to me that also the 1.1.0.21 has missed the subscriptions.

    What are the options? We are going to online with our R2 migrated site as soon as the subscribers are back.

    Thank You for Your help, Per!

    #26552 Edited, Dec 10, 2008 20:16
  • Member since: 2003
     

    Has anyone had success migrating subscriptions from 4.62 to 5 R2?

    Anyone? Huhuu? Surprised

    #26567 Dec 11, 2008 14:54
  • Member since: 1999
     

    Could be a bug but I have registered a support case for you.

     

    #26575 Dec 11, 2008 17:45
  • Member since: 2007
     
    our users didnt get any subscriptions settings either. Did the migration twice and it didn't work.
    #27174 Jan 19, 2009 15:57
  • Member since: 2007
     

    Don't know if this will help you but we made a little loop that picked up users from the old DB and just updated the new DB with their settings.

    Its simple and works good. You can read it @ 

    http://www.from-rizo.se/2009/01/21/user-migration-from-episerver-4x-to-cms5r2/

     

    #27314 Jan 26, 2009 15:58
  • Member since: 2008
     

    Hi,

    This has now been confirmed to be a bug with the Migration tool.

    #20255: Subscriptions are not migrated if you have a none globalized site.

    The issue was that if you have a EPiServer 4 site that isn't globalized, you will have different values in the database on tblUserProperty.

     

    #27518 Feb 02, 2009 10:47
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply