WPiServer Scheduler loads no sites

Member since: 2007
 

I got the message in admin mode saying that the EPiServer Scheduler were not running. Checking the server everything seems to run fine but when I run the Scheduler in DEBUG mode I get this result:

#INF# *************************************************** #INF# * EPiServer Scheduler Service running in DEBUG mode #INF# *************************************************** #INF#  \  \  setting in .config may prevent full exception details from being r eturned by remoting framework #INF# RegisterChannel #INF# Testing service connection #INF#  Enumerating Registered Services types: #INF#   type='EPiServer.Scheduler.External, EPiServer.SchedulerSvc'; objectUri=S ervice.rem; mode=SingleCall #INF#  Probing connection: #INF#   PING! #INF#   PONG! #INF#   Connection OK #INF# Loaded queue with 0 sites: #INF# Service started - begin accepting connections

It doesn't load any sites. We are running WS 2003 x64 don't know if this has something to do with the problem since the Scheduler lies in the Program Files folder (not x86). All thoughts greatly appreciated!

#26263 Nov 28, 2008 9:11
  • Member since: 2008
     

    Hi Tobias,

    Tried the FAQ on the subject?

     

    #26264 Nov 28, 2008 9:40
  • Member since: 1996
     

    Hi Tobias!

    Also make sure that the EPiServer.Scheduler.Initializer httpModule is configured correctly in web.config:

    <httpModules>
     <add name="Initializer" type="EPiServer.Scheduler.Initializer, EPiServer.Scheduler" />
      ...
    </httpModules>

    An easily overlooked mistake is to not move the httpModules section to <system.webServer> when running IIS7 with the Integrated Pipeline.

    This can be done by using the "appcmd Migrate Config" tool.

    /johan

    #26268 Nov 28, 2008 12:12
  • Member since: 2007
     

    Petter: read all the resources I've found without any luck. Removed the Sites file and restarted but still the same.

    Johan: the web.config is correct and we don not run IIS7

    Any more options to try because so long nothing has helped

    #26281 Dec 01, 2008 10:27
  • Member since: 1996
     

    Do you see anything (errors) in the logfile?

    /johan

    #26285 Dec 01, 2008 11:35
  • Member since: 2007
     
    All the logfile says is the same as stated above. All seems fine but there seems to be some problems connecting the site to the scheduler since it loads no sites.
    #26291 Dec 01, 2008 16:19
  • Member since: 1996
     

    If you set LogLevel = "All", you'd see some entries coming from "Microsoft.Samples.Runtime.Remoting.Channels.Pip.DBG.Info"

    Something like this:
    2008-12-01 17:21:40,441 INFO [7] Microsoft.Samples.Runtime.Remoting.Channels.Pipe.PipeClientTransportSink.SendWithRetry - 18.3.1 Scheduler info:  Look in pipe connection in pool
    2008-12-01 17:21:40,441 INFO [7] Microsoft.Samples.Runtime.Remoting.Channels.Pipe.DBG.Info - 18.3.1 Scheduler info:  4152> Write string pipe://EPiServer.Scheduler/Service.rem
    2008-12-01 17:21:40,441 INFO [7] Microsoft.Samples.Runtime.Remoting.Channels.Pipe.DBG.Info - 18.3.1 Scheduler info:  4152> Write ushort 65441
    2008-12-01 17:21:40,441 INFO [7] Microsoft.Samples.Runtime.Remoting.Channels.Pipe.DBG.Info - 18.3.1 Scheduler info:  4152> Write string Content-Type
    2008-12-01 17:21:40,441 INFO [7] Microsoft.Samples.Runtime.Remoting.Channels.Pipe.DBG.Info - 18.3.1 Scheduler info:  4152> Write string application/octet-stream
     

    It would be interesting to see if you get any errors amongst these calls.

    /johan

    #26294 Dec 01, 2008 17:24
  • Member since: 2007
     

    Johan, where do you mean I should use the LogLevel command?

    The way I'm debugging is according to this

    #26317 Dec 02, 2008 10:37
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply