Error - ASPNET is not a valid user or group

Member since: 2007

I am trying to install a new site on our Windows 2003 server machine but every try gives me the error message "Error - ASPNET is not a valid user or group".

This seems very strange since this is a Windows 2003 machine which doesnt use the ASPNET account. Does anyone have any idea why this is occuring?

#25996 Nov 17, 2008 9:44
  • Member since: 2002

    That sounds strange, 2003 sever does not have the aspnet user... Which version are you trying to install? And are you using the SDK installation, or the manager? 

    Lars Øyvind 

    #26088 Nov 20, 2008 7:20
  • Member since: 2007
    I am trying to install the latest R2 release and I am doing this using the manager.
    #26092 Nov 20, 2008 9:38
  • Member since: 2007
    Just to make sure, EPiServer Manager 2.0.19.x or EPiServer Installation Manager?
    #26102 Nov 20, 2008 11:19
  • Member since: 2002
    And, you're doing this on a "clean" iis site? You haven't done any manualaspnet_isapi.dll configuration?
    #26108 Nov 20, 2008 11:45
  • Member since: 2007

    It is the EPiServer Installation manager from the latest R2 release.

     If you by Clean mean a new web site then no. I tried to install it as a virtual directory under an existing web site by providing an application name.

     I'm not sure exactly what you mean by manualaspnet_isapi.dll. I have checked the "ISAPI filters" tab on the website and that was empty and if I click the configuration button on the web site there is no such dll in the Application extensions list.

    #26298 Dec 01, 2008 18:45
  • Member since: 2004

    Did you resolve this? I have the same problem with a Windows 2003 Server, and I get this error after I have put all the credentials into the Installation Manager with R2 and start to install a web site.


    #26729 Dec 17, 2008 13:39
  • Member since: 2008

    This looks similar to the problem I had, see


    #26732 Dec 17, 2008 14:36
  • Member since: 2004
    Seems that the ASPNET account must exist on the server in order for the installation to complete, although the Network account is later used as worker process for the installed site. Don't really understand why, but problem solved. Thanks for the reply, Henrik.
    #26793 Dec 22, 2008 0:35