Search in File Manager not working

Member since: 2007
 
The file manager works, but i can not search. When selecting, for example, "Search locations: Documents (/SomeSite/Documents/)" and click "Search" I get the following error message: "VirtualPathProvider 'SiteDocuments', Search Error: C:\Inetpub\CMSAssets\Documents\index not a directory" I tried different configurations in web.config but with no success. Help would be appreciated! /Jonas
#17775 Feb 08, 2008 11:39
  • Member since: 2007
     

    I've just installed a testsite with the public templates. When I try the search funticon i get the same error but for a different folder:

    C:\EPiServer\VPP\MyEPiServerSite\Global\index not a directory

    The public templates uses

    SearchDataSource.SearchLocations = "~/Global/,~/Documents/,~/PageFiles/";

    But something is clearly wrong.

    #27625 Feb 04, 2009 15:21
  • Member since: 2005
     

    Hi

    To be able to search in the file system the we use the EPiServer indexing service. The indexing service will create a folder called index where it will store a few files with the indexed data. It's that folder that seems to be missing.

    So, my guess is that EPiServers indexing service is not configured for those folders. Check the file *Program Files*\EPiServer\Shared\Services\Indexing Service\EPiServer.IndexingService.exe.config (the location might vary depending on version of EPiServer CMS).

    The section episerver.indexingService\indexes should contain registrations for the different folders. A registration should be on this form:

    <add connectionString="Data Source=.\sqlexpress;Database=myDB;User Id=username;Password=password;Network Library=DBMSSOCN;" databaseClient="" filePath="C:\Inetpub\CMSAssets\Documents\index " itemRoot="/Documents" />

    Regards

    Per Gunsarfs
    EPiServer CMS development team

    #27643 Feb 05, 2009 9:08
  • Member since: 2007
     

    I played around a bit and it seems that you have to stop and restart the indexing service before it starts indexing new content for another site.

     

    #27656 Edited, Feb 05, 2009 14:24
  • Member since: 2016
     

    I did try restart the service but ended up with no result. Is there something else that may be bothering the service?

    #174712 Feb 02, 2017 16:45
  • Member since: 2008
     

    Eric: Are you not getting the service to start indexing, or did it index but is returning no results?

    #174902 Feb 07, 2017 15:15