Scheduled Jib fails when run by the Scheduler

Member since: 2003
 
My custom scheduled job fails when run by the scheduler. The job is changing, deleting and moving pages. I guess it has to do with credentials/account/access rights. When I run it manually from the admin interface it works well. It also fails when using a domain account which has admin rights in EPiServer. Any ideas anybody? Regards, Frode
#17692 Aug 28, 2007 7:21
  • Member since: 2003
     
    Try using the NoAccess value for the AccessLevel parameter: EPiServer.Global.EPDataFactory.Save(pageObject, EPiServer.DataAccess.SaveAction.Publish, PiServer.Security.AccessControlList.NoAccess);
    #18537 Aug 28, 2007 8:30
  •  
    Hi! I have the same trouble but with the ordinary Archiving function?! The job is executed every day, and the historic log says "OK" on Status and "0 pages were removed", every day. But when archiving manually by pressing the button it works fine. From "0 pages were removed" to "46 pages were removed" Other scheduled jobs work fine on our web site, including those made by us!? Best Regards Mats Bernerfalk
    #18538 Jan 23, 2008 8:30
  •  

    Hi Mats,

     When using reflector on the archiving function you can se that the archiving loop is inside a try/catch and that the system only counts up the one that is ok. there is no handling of the ones that fails so that when the loop is done the count is still 0 and thus giving you a "0 pages were removed" message. the most likely reason is that since the scheduled job is run as anonymious when in automatic mode you get an access denied error on each page (the manually is run as the user loged in).

    Maybe EPiServer in the future can give a count on the ones getting access denied as well as the ones going OK?!

    -Kjetil Simensen

    #26255 Nov 27, 2008 15:19