Episerver Find not working for content or blocks

Member since: 2014

Hello All!

 I have a site where the search for the pages and the blocks are not working - keeps throwing up the "Content not found" 

so far i have tried uninstalling it and reinstalling it. 

i can hit this ok 

http://mysite/IndexingService/IndexingService.svc

and get the end point not found 

i can get to here

//EPiServer/CMS/Admin/IndexContent.aspx

and it runs fine but when i go t the specfied location the folder is empty. 

the folder permissions seem ok aswell - not too sure what is going on. 

any help provided would be much appraciated.

#175618 Edited, Feb 24, 2017 10:48
  • Member since: 2004

    Make sure Find is selected under Admin / Config / Search Configuration.

    #175673 Feb 27, 2017 9:57
  • Member since: 2014

    Hello Erik 

    I've double checked my settings and everything seems in check all the items in thel ist are checked but still no joy.

    Kind regards,

    Hannah Mathews 

    #175689 Feb 27, 2017 15:03
  • Member since: 2003

    Hi Hannah

    What you are describing looks more like trouble with Episerver Search and not Episerver Find.

    Check out these blog-posts for more trouble shooting.

    http://world.episerver.com/blogs/Henrik-Fransas/Dates/2015/8/setup-episerver-search-in-a-future-safe-and-stable-way/

    http://sveinaandahl.blogspot.no/2013/06/how-to-install-episerver-search-for.html

    Regards

    /Mikael

    #175690 Feb 27, 2017 15:15
  • Member since: 2004

    Make sure Find alternatives are at the top (drag and drop). Imo it's not necessary to have both of them selected unless you exclude a lot in your Find index.

    #175692 Feb 27, 2017 16:13
  • Member since: 2014

    Found the solution - it was the directoryPath that was the issue was that the path was hard coded where it should have been [appDataPath]. Once this was updated everything started working as expected! 

    Thank you all very much for your advice ! 

     

    #176086 Mar 09, 2017 13:39