Delay before comments show up?

When a new comment is placed on our site we send an email to notify administrators that a new comment has been placed. They've reported that it sometimes takes a while before that comment shows up on the page for them.

We're not quite sure if this is an issue in our implementation or not but I wanted to check if there's any internal replication going on in the service that might cause this?

That is; a user places a comment and that is saved on a storage node in Episerver Social. We send the email to adminstrator. The administrator goes to the page to look at the comment and perhaps respond. The administrator loads comments from another storage node than where the comment was placed so it then takes a few reloads before either the replication is done or until the administrator queries the "correct" storage node.

Is this something that could happen?

#174387 Jan 25, 2017 13:11
  • Member since: 2015

    Hi Anders,

    Presently, Episerver Social processes comment operations as the requests are received. All of the nodes making up the service's cloud ultimately deliver data from a common repository and don't maintain or pool any individual state. So, there should be no noticible delay between adding a comment and it being available to you in your queries. By the time the comment service returns control to your application, the comment should be available.

    This is also true of the Ratings, Moderation, and Groups features. The Activity Streams feature does queue activities when generating feed items for subscribers and therefore could produce a noticable delay between the activity occuring and subscribers seeing it represented in their feeds.

    Is it possible that there is some page level or client-side caching that may be interfering? One way to isolate certain possibilities might be to attempt to reproduce the behavior from dedicated console/web app.

    #174405 Jan 25, 2017 19:51