Problems installing CMS R2 SP1



I have installed CMS R2 SP1 on my testserver, a w2k8 64bit. Then i try to create an empty web site from the Deployment Center by not selecting to install templates and content. I want a completely emty episerver website to which I can deploy my own project files from my development machine and create pagetypes and pages in edit/admin-mode. When i try to enter the edit/admin mode i get a message saying "some content files are missing". I would expect to enter edit-mode seeing only the rhe root-folder and the recycle bin. Have i missunderstood something? Do I really have to install the public templates and content?

#28222 Feb 25, 2009 22:17
  • Lars Bodahl
    Member since: 2002

    The first thing you could check, is that the virtual paths are set up correctly in web.config. Util, App_Themes_Default, WebServices and YourCustomEditAdminPath should be mapped to "C:\Program Files\EPiServer\CMS\5.2.375.7\xxx" 

    I haven't tried this on an R2 SP1 site yet, but when R2 first came out, we had problems installing sites on a different drive than the C-drive. Our workaround was to install the site on the C-drive and then move it to the other drive. 

    Not sure if this is your problem, but the error message indicates that there are something wrong with your vpp folders...

    Lars Øyvind Bodahl 

    #28226 Feb 26, 2009 7:49

    Hello! And thx for reply!!!       

    I checked the paths and they seem ok to me. On 64bit the appfiles are located in Program Files (x86) but that is reflected in web.config also...:

            <add name="App_Themes_Default" virtualPath="~/App_Themes/Default/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\App_Themes\Default" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
            <add name="UI" virtualPath="~/SEC/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\UI" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
            <add name="UtilFiles" virtualPath="~/Util/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\util" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
            <add name="WebServiceFiles" virtualPath="~/WebServices/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\webservices" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />

    The message I  get after logging in to the Edit-mode is: 
    Install Basic Content  
    Some basic content is needed in order to start using EPiServer CMS. Select one of the options below, a system language and click Finish.
     No import package folder was passed via querystring parameter
    The ~/util/setup folder does not contain any packages
    The manager's modules folder does not contain any packages [C:\Program Files\EPiServer\Manager\Modules]
     Anyone have a solution to this? Am I doing something wrong?


    #28228 Feb 26, 2009 8:07
  • Per Bjurström
    Member since: 1999

    There is a long story behind this behaviour, I won't go into that now. 

    The redirect only happens when pageStartId does not contain a valid value, so set pageStartId in web.config to 1 or something and you should be good to go.


    #28234 Feb 26, 2009 13:52
    Works. All I needed, thx!
    #28239 Feb 26, 2009 21:43