Trying to upgrade CMS and Commerce to latest version 11.2.1

 

Hi

I am trying tto upgrade CMS and Commerce, but I getting a error about som EPiServer.Cms.AddOns.Blocks is not compatible.

"Error Unable to resolve dependencies. 'EPiServer.CMS.Core 11.2.1' is not compatible with 'EPiServer.Cms.AddOns.Blocks 2.3.1 constraint: EPiServer.CMS.Core (>= 10.10.4 && < 11.0.0)'. "

I any idea what to do?

Thanks

Juan

#185901 Dec 06, 2017 9:25
  • Vincent Baaij
    Member since: 2016
     

    Hi,

    That is the EPiServer Self-Optimizing Block package and is indeed not yet available for Episerver CMS 11. A solution is to unistall this package and try the update again. You can re-add it when a new, compatible, version of the package comes out.

    #185905 Dec 06, 2017 10:35
  •  

    Hi @Vicent

    Do you mean that I need to remove EPiServer.Cms.AddOns.Blocks and then upgrade to 11, and after upgrade add EPiServer.Cms.AddOns.Blocks again?

    #185907 Dec 06, 2017 10:39
  • Vincent Baaij
    Member since: 2016
     

    Yes on remove and upgade.

    Install the package again after a new compatible version is released (so not right after the upgrade)

    #185908 Dec 06, 2017 10:41
  •  

    ok, but we are using the EPiServer Self-Optimizing Block...

    I guess I have to wait for a new vercion before I upgrade.

    /Juan

    #185910 Dec 06, 2017 10:58
  • Vincent Baaij
    Member since: 2016
     

    Sorry, yes then you need to wait

    #185911 Dec 06, 2017 11:03
  •  

    Thanks Vincent!

    #185912 Dec 06, 2017 11:13