WebDAV access

Peter Bergqvist
Member since: 2006


One of my clients has requested that we set up WebDAV access during the build-up of their new site (lots of images to upload). The WebDAV access will be on interal staging environment only.

I've followed the installation steps on my local environment, but I have never been able to log on.. There was a patch to install and also a registry fix but none of those steps solved the issue.

If I remove the <deny users="*" /> attribute I am able to map the network drive but I don't have write access.

Any tips to lead me forward on this? If I just want access on a few days I can live with full access for everyone and then remove all webdav configuration 

Best regards,


#26109 Nov 20, 2008 12:01
  • Peter Bergqvist
    Member since: 2006
    Never mind, I go for the advanced file upload component instead =)
    #26111 Nov 20, 2008 15:08

    We get the very same problem on a site running CMS 5.1.422.256. Configured the server and the client as per instructions here:


    Can only get read-only access for a WebDAV folder when <deny users="?"> is removed (anonymous logon). This is not an option as our client obviously needs protection for the web folder. Tried BasicAuthentication, tried NetDrive and BitKinex clients but cannot get user authentication working. We always get 401 Unauthorized.

    Are there any settings to EPiServer.WebDAV that we may try?

    #41862 Jul 30, 2010 19:46
  • adam.jenkin
    Member since: 2011

    Did you guys ever find a solution to this? I have the same issue. Works in read-only mode when removing <deny users="*" /> but cannot get it to work with either windows or sql membership provider accounts.

    I know basic auth is working correctly on my site as I am using on the webservices folder for security.

    #60991 Sep 03, 2012 17:52
  • Stephan Lonntorp
    Member since: 2005

    Adam, did you ever solve it?

    I've got <deny users="?" />, and it's working in read-only mode, however, I can't get write-access to work.

    #61945 Oct 08, 2012 13:06
  • Dmytro Duk
    Member since: 2008

    Check if standard WebDAVModule is enabled on your IIS site. It can overlap with other modules that uses OPTIONS and PUT and you may get different kind of errors depending on the client.

    Please see this blog post for more details and debug techniques.

    #61963 Edited, Oct 08, 2012 18:17