Too many redirects error in the browser after package update.

I have updated packages to the latest version and get too many redirect error in the browser. It seems that Commerce migration page requires authenticated admin so it redirects to Login page but Login page redirects back to Migrate page as Commerce DB is not migrated yet.

I have Commerce 9.23.0 installed and it was updated from 9.19.1. I am also using EPiServer.CMS.UI.AspNetIdentity package for authentication.

Is there any way to disable redirect to the migration page from the login page or allow an anonymous user (temporarily) run the migration.

#160676 Oct 03, 2016 12:49
  • Hi,

    Technically you can set the migration steps to run automatically, so you won't have to login and click on "Execute remaining steps". You can do that by set "AutoMigrateEPiServer" key in appSettings to true.

    We'll look into the redirection and see if we can improve the sitation.

    Regards,

    /Q

    #160680 Oct 03, 2016 13:27
  • Thanks, Quan. It helped. We had auto migrate in the episerver.framework section but didn't know about an option to auto migrate commerce.

    #160681 Oct 03, 2016 13:33
First   1   Last