offline, can't save - error

Hello,

Sometimes when i´m adding content to a page the autosave tells me "offline, can't save" - error and i can´t publish or save. 

It happens very randomly and sometimes it helps to wait a while and other times i have to log in and log out.

 

Does someone any solution to this problem?

Thanks in advance!

 

//André

#64022 Dec 07, 2012 11:38
  • I got the same error when using pagetype properties of type 'long'. Immediatelly after setting a value in the content editor the error appeared. Changing the 'long' to an 'int' in the PageType definition seems to remove the problem.

    #64029 Dec 07, 2012 16:42
  • Check the network trafic when this happens and perhaps you are able to view a more detailed error message that you can post to help us investigate this.

    #64032 Dec 07, 2012 17:43
  • Thanks for your answers.

    I will try to check the network trafic and see if i can

    figure it out from the error message.

     

    Thanks again!

    //André

    #64079 Dec 10, 2012 16:07
  • I'm getting the same thing but I'm running totally local. I can find the file that I uploaded and I can serve it up through my browser using the /PageFiles/x/file.jpg. It just won't load into my page type, render or save what I put in. Is there a configuration setting I need to enable? This looks like a bug in 7 that's going to be a big problem once my non-developers start using the CMS.

    #64163 Edited, Dec 11, 2012 18:07
  • Had the same problem. I solved similar to Rene de Wit. My problem was  where i defined my blockdata properties. I had defined a imageurl to string 

    however it should be of type Url. Look below:

    Offline-error

    [ContentType]
    public class TextImageBlock : BlockData
    {
    public virtual string BlockHeading2 { set; get; }
    [BackingType(typeof(PropertyImageUrl))]
    [Display(
    Name = "Image Url",
    Description = "",
    // GroupName = SystemTabNames.Content,
    Order = 1)]
    public virtual stringImageUrl { get; set; }
    }

     

    No more offline-error

    [ContentType]
    public class TextImageBlock : BlockData
    {
    public virtual string BlockHeading2 { set; get; }
    [BackingType(typeof(PropertyImageUrl))]
    [Display(
    Name = "Image Url",
    Description = "",
    // GroupName = SystemTabNames.Content,
    Order = 1)]
    public virtual Url ImageUrl { get; set; }
    }

     

    #64176 Dec 12, 2012 10:22
  • When I change the type to Url, I'm getting build error for the Url object. The option I'm given is to utilize System.Security.Policy which ultimately throws an error when trying to render in the CMS.


    What library reference do I need to use?

    #64198 Dec 12, 2012 18:53
  • using EPiServer;

     

    #64210 Dec 13, 2012 8:40
  • That did it. Don't know why VS didn't pick that up as a possibility.

    #64236 Dec 13, 2012 22:45
  • Hi,

    We are randomly getting the same error as André. Have checked all Images, but all are defined correctly.

    [BackingType(typeof(EPiServer.SpecializedProperties.PropertyImageUrl))]
    [Display(Name = "Ikon",
    Description = "Ikon för listningssidan",

    GroupName = SystemTabNames.Content,
    Order = 2)]
    public virtual Url Icon { get; set; }

    This seems to be a very annoying bug.  @EPiServer: Do you want me to issue a trouble report?

    Christian Wallgren

     

    #64378 Dec 18, 2012 16:29
  • Hi!

    I agree that it's really anoying to get this incorrect and generic error message when there actually seems to be an exception thrown on the server. I have reported the following but to at least make sure we show a proper error message, preferrably with the option to see a stack trace:

    Bug #92986: "Offline, can't save" error message are shown though the error seems to occur on the server for several reasons
     
    Regards
    Linus Ekström
    EPiServer Development Team
    #64389 Dec 18, 2012 20:51
  • Hi!
    Good. Because the worst problem isn't the message but the fact that the error occurs, i.e. the material isn't saved. We also have an unconfirmed issue from the customer, that the save-versions are mixed-up between pages, in connection with the error message. The customer claims that the content has been saved on the wrong page.

    Regards

    Christian

    #64397 Dec 19, 2012 9:41
  • I had the same problem when saving images. When using PropertyImageUrl use public virtual EPiServer.Url instead of string..

    #64403 Dec 19, 2012 11:41
  • Christian: I you have not already solved your issue, I think contacting support is the way to go for your specific problem.

    #64415 Dec 20, 2012 8:32
  • I experienced this issue for properties of the type EPiServer.Core.PropertyPageType, and fixed it by changing my property from

    public virtual int PagePointer { get; set; }

    to

    public virtual PageType PagePointer { get; set; } 

    #73389 Edited, Jul 17, 2013 15:09
  • This seem to happen when there is a mismatch between the type that is saved and the type of the property - i.e. Peter's post above using string instead of Url.

    #74295 Aug 23, 2013 13:25
  • We had this also. In our case it was caused by an [StringLength(320)] decoration on a XhtmlString property.

    #77079 Nov 07, 2013 16:00
  • I got the same issue, and it's from string to string[]. It's happen after we migrate from CMS 6 to 7.5. The problem is this error occur randomly. Just one page type, but most of page are save succeed, just few of them got this issue. So annoying

    #82240 Mar 09, 2014 6:06
  • I switched to ContentReference, I kept encountering the same issue. After I restarted my machine, everything worked. 

    #82245 Mar 10, 2014 4:42
  • We have a customer who is experiencing the same error: "Offline, can't save" on random occasions.

    The possible causes mentioned above could not be found in the sources of the website.

    I retrieved the following error/stacktrace from the log4net error logging at the time the error took place on the website:

    2014-03-13 15:51:28,730 [29] EPiServer.Global.Global_Error(:0) - 1.2.5 Unhandled exception in ASP.NET
    System.Web.HttpException (0x80004005): Version is not writeable
       at EPiServer.Cms.Shell.UI.Rest.ContentChangeManager.UpdateContentProperties(ContentReference contentReference, IDictionary`2 properties, SaveAction saveAction)
       at EPiServer.Cms.Shell.UI.Rest.ContentDataStore.Patch(PatchContentDataModel entity)
       at lambda_method(Closure , ControllerBase , Object[] )
       at System.Web.Mvc.ReflectedActionDescriptor.Execute(ControllerContext controllerContext, IDictionary`2 parameters)
       at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary`2 parameters)
       at System.Web.Mvc.ControllerActionInvoker.<>c__DisplayClass13.<InvokeActionMethodWithFilters>b__10()
       at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodWithFilters(ControllerContext controllerContext, IList`1 filters, ActionDescriptor actionDescriptor, IDictionary`2 parameters)
       at System.Web.Mvc.ControllerActionInvoker.InvokeAction(ControllerContext controllerContext, String actionName)
       at EPiServer.Shell.Services.Rest.RestControllerBase.ExecuteCore()
       at System.Web.Mvc.ControllerBase.Execute(RequestContext requestContext)
       at EPiServer.Shell.Services.Rest.RestHttpHandler.ProcessRequest(HttpContextBase httpContext)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Does anyone have any clue on where to look next?

    #82577 Mar 14, 2014 16:42
  • @Linus

    What happened to this bug? Bug #92986

    I noticed your post is from 2012 but I still experience the "offline, can't save" error... 

    Running EPiServer 7.7

    #87504 Jun 16, 2014 10:23
  • @Josef +1

    #88388 Jul 10, 2014 13:51
  • @Linus (and @Josef)

    We have the same problem as Erwin van der Stelt. 

    System.Web.HttpException (0x80004005): Version is not writeable

    #114762 Dec 19, 2014 14:18
  • We've just experienced the "Offline, can't save" issue when inserting images from Global Assets into a XHTML property. No exceptions were thrown. It turned out the Web Application Firewall (WAF) was complaining that it was a possible XSS attack. We had to add a firewall exception for the block type to resolve the issue. Weird.

    #151854 Aug 09, 2016 5:45
First   1   Last