ERROR: "Column 'SecondsAfterLastPing' does not belong to table Table"

Member since: 2008

Good day,

I ran into an error today that for the life of me, have no idea how it appeared or how to fix it.  If someone has ran into this problem and has fixed it, PLEASE enlighten me.

ERROR: "Column 'SecondsAfterLastPing' does not belong to table Table"

[ArgumentException: Column 'SecondsAfterLastPing' does not belong to table Table.]
   System.Data.DataRow.get_Item(String columnName) +3108760
   EPiServer.DataAbstraction.ScheduledJob.Create(DataRow row) +1649
   EPiServer.DataAbstraction.ScheduledJob.List() +299
   EPiServer.DataAbstraction.ScheduledJob.Load(String method, String typeName, String assemblyName) +76
   EPiServer.UI.Admin.DatabaseJob.OnLoad(EventArgs e) +459
   System.Web.UI.Control.LoadRecursive() +71
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3064


This happens on every single scheduled job.  As soon as I click on the link to view a scheduled job, this error displays.

Thanks.  Joshua

#56972 Feb 19, 2012 22:20
  • Member since: 2008

    I've seened to stumble across the problem.  The stored procedure for netschedulerlist was wrong.

    	SELECT CONVERT(NVARCHAR(40),pkID) AS pkID,Name,CONVERT(INT,Enabled) AS Enabled,LastExec,LastStatus,LastText,NextExec,[DatePart],Interval,MethodName,CONVERT(INT,fStatic) AS fStatic,TypeName,AssemblyName,InstanceData, IsRunning, CurrentStatusMessage
    	FROM tblScheduledItem
    	ORDER BY Name ASC

        I had to change it to this.

    Select CONVERT(NVARCHAR(40), pkID) AS pkID, Name, CONVERT(INT,Enabled) AS Enabled, LastExec, LastStatus, LastText, NextExec,[DatePart], Interval, MethodName, CONVERT(INT,fStatic) AS fStatic, TypeName, AssemblyName, InstanceData, IsRunning, CurrentStatusMessage, DateDiff(second,LastPing,GetDate()) as SecondsAfterLastPing
    FROM tblScheduledItem
    ORDER BY Name ASC

        In case anyone else runs across the problem

    #56973 Feb 19, 2012 23:06
  • Member since: 2004

    I think this has to do with having the hotfix pack of EPiServer 6 R2 installed on the machine, but the database isn't upgraded. Could that be the case here as well?

    #56975 Feb 20, 2012 9:47
  • Member since: 2006

    Hi I got this error, running the SchemaUpdate.sql solved the problem.

    http://world.episerver.com/PageFiles/110367/SchemaUpdate.sql

     

     

    #57015 Feb 21, 2012 15:28
  • Member since: 2008

    Hi, 

    We are already aware of this issue and are looking into it. Seems like upgrade scripts for R2 doesnt have the latest changes for schema update as mentioned in my blog post. 

    Temporary workaround is to run the Schema Update script manually for now.  

    #57028 Feb 22, 2012 9:32
  • Member since: 2003

    I got this problem too. I can confirm the script fixed it. Thanks Shahid Nawaz :) 

     

    #57447 Edited, Mar 14, 2012 20:05
  • Member since: 2008

    Thanks for this post Joshua, this saved me a lot of troubleshooting on my current project. Guess that's another blemish on the CMS 6 R2 hotfix then.

    #58385 Edited, Apr 23, 2012 10:00
  • Member since: 2004
    #59195 Removed, May 23, 2012 22:51
  • Member since: 2008

    Any fixes for this on the way? It is pretty fast to fix but would be nice with a hotfix :)

    #59689 Edited, Jun 21, 2012 15:08
  • Member since: 2008

    I think this was in the latest hotfix Simen.  I could be wrong but I am pretty sure it was put in there.

    #59690 Jun 21, 2012 16:06
  • Member since: 2008

    Ok, thats good news :)

    #59691 Jun 21, 2012 16:14
First   1 2   Last